RE: Any assistance appreciated: Dynamic Server Initialisation Fai
Posted in 2005
Neil,
The result of the restore was such that onbar reported that it had
completed all of the DBSpaces, without error, and when it was instantiating
to online mode it vanished, the message log did not record any errors, no
af.* or shmem.* files were generated. Yet the instance was not online. A
subsequent attempt to bring it online yielded the output shown as the oninit
-v output, there were still no entries in either the log or any files
generated yet still it remained off-line.
There were no old or other oninit processes running.
There were no old shared memory segments remaining.
All of the executables, directories, paths, configuration files for
informix, and the system are valid, with correct permissions in the correct
places.
The /etc/services /etc/hosts are in good order.
The $INFORMIXDIR/etc/sqlhosts is valid all entries are valid all
services and machines are valid.
The $INFORMIXDIR/etc/$ONCONFIG is valid, now extraneous or
unsupported entries.
The $INFORMIXDIR/etc/oncfg_${INFORMIXSERVER}.<servernum> contents
are valid.
The instance configuration has not changed.
The hardware has not changed.
Although we are preparing to upgrade from omniback to dataprotector
this has not been deployed on the machine having problems.
The tape unit being used for the restore is the same unit used for
the backup.
The same version of Informix was used for the backup and the
restore.
We are reverting to a database that is about 10 days old, and in
that time there have been no releases of software, libraries, configuration
changes or hardware changes either requested or enacted for the machine.
This database is approximately 400Gb in size, and as I mentioned, I
simply do not have time to start another restore without:
a) Guarantees of success (why would another work when 3
previous attempts have failed all with different tapesets).
b) Serious ramifications on the business.
We have held concerns about our backups for some time, and have
plans to upgrade our backup systems, and have a very large LTO2 unit
configured on the SAN now, but that is still weeks from implementation, and
until this point the cold restore although a 30+ hour task has worked.
None of these really change the situation though, I don't have a
database and I do have a headache. :). I have started a restore of selected
dbspaces, from yet another set of tapes in the library and hopefully steps
can be advanced.
On a side issue: The case has been escalated by the IT manager with
our IBM rep, as the support numbers in aust are unavailable ??, I will try
again in a few minutes, we did get a resolution to that, we now have a
number for 24x7 support that is a U.S. phone number... But I can't find a
phone in our office that permits international calls... :( ... If you didn't
laugh you'd cry.
Cheers,
Cliff.
-----Original Message-----
From: Neil Truby [mailto:neil.truby@ardenta.com]
Sent: Saturday, 22 January 2005 8:36 PM
To: informix-list@iiug.org
Subject: Re: Any assistance appreciated: Dynamic Server Initialisation
Failure
Am I missing something here? Wouldn't you expect, at the end of the
restore, the database to be sitting in quiescent mode expecting you to bring
it onlone with an onmode -m? What then was the necessity to do the oninit?
Or am I very old and confused?
"Burton, Clifford" <clifford_burton@simplus.com.au> wrote in message
news:1106381417.1c1a8c8b9eef6b87f2adabdb982013d7@teranews...
>
>
> Hi All,
>
> I have a situation where the IDS-731UD4 instance I run on HP-UX 11 is
> failing after a cold restore.
>
> I do not have time to perform another restore without serious business
> ramifications.
>
> The output from the log file is: the last lines:
> 09:47:30 Could not create single shared memory segment with resident> and non-re sident partitions. Proceeding to create 2 shared memory
> segments instead.
> 09:47:32 Segment locked: addr=0xc1841000, size=683679744>
> Sat Jan 22 09:47:32 2005
>
> 09:47:32 Event alarms enabled. ALARMPROG =
> '/apps/informix_ids/etc/ifx_alert.sh'
> 09:47:38 DR: DRAUTO is 0 (Off)
> 09:47:39 Dynamically allocated new message shared memory segment
> (size
> 1104KB)
>
> 09:47:39 Informix Dynamic Server Version 7.31.UD1 Software Serial> Number
> AAD
> #J216570
> 09:47:39 Informix Dynamic Server Initialized -- Shared Memory> Initialized.
> 09:47:39 Physical Recovery Started.
> 09:47:39 Physical Recovery Complete: 0 Pages Restored.
> 09:47:39 Logical Recovery Started.
> 09:47:42 Logical Recovery Complete.> 0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
>
> However:
>
> informix@machinename$ onstat -> shared memory not initialized for INFORMIXSERVER 'newworld'
>
> The results of the oninit -v are:
>
> Checking group membership to determine server run modesucceeded
> Reading configuration file
> '/apps/informix_ids/etc/onconfig.newworld'...succeeded
> Creating /INFORMIXTMP/.infxdirs ... succeeded Creating infos file
> "/apps/informix_ids/etc/.infos.newworld" ...
> "/apps/informix_ids/etc/.conf.newworld" ... succeeded Writing to infos
> file ... succeeded Checking config parameters...succeeded Allocating
> and attaching to shared memory...succeeded Creating resident pool
> 143252 kbytes...succeeded Creating buffer pool 524290
> kbytes...succeeded Initializing rhead structure...succeeded
> Initializing ASF ...succeeded Initializing Dictionary Cache and Stored
> Procedure Cache...succeeded Bringing up ADM VP...succeeded Creating VP
> classes...succeeded Onlining 4 additional cpu vps...succeeded Onlining
> 18 IO vps...succeeded Forking main_loop thread...succeeded Initialzing
> DR structures...succeeded Forking
> 1
> 'ipcshm' listener threads...succeeded Forking 2 'soctcp' listener
> threads...succeeded Forking 1 'ipcshm' listener threads...succeeded
> Forking 0 'soctcp' listener threads...succeeded Forking 0 'soctcp'
> listener threads...succeeded Starting tracing...succeeded Initializing
> 32 flushers...succeeded Initializing log/checkpoint
> information...succeeded Opening primary chunks...succeeded Opening
> mirror chunks...succeeded Initializing dbspaces...succeeded Validating
> chunks...succeeded Initialize Async Log Flusher...succeeded Forking
> btree cleaner...succeeded Initializing DBSPACETEMP list Checking
> database partition index...FAILED
> oninit: Fatal error in shared memory initialization
>
>
> I realise that it is unlikely that too many people are out there right
> at this moment, however, I have been working on this issue so long now
> that I am loosing track of time, Does anyone have any ideas as to how
> to get this online, I do have a vague recollection of an issue like
> this in the past that was resolved quite simply. I am attempting to
> contact IBM Support on the issue although it is a moderately complex
> task out of hours when I cannot locate the support contracts etc...
>
> Clifford Burton
> Senior Database Administrator
> SIMplus Mobile Pty Ltd [ www.SIMplus.com.au
> http://www.simplus.com.au/> ]
> Ph: (02) 9028 1716
> Fx: (02) 9030 6284
>
>