Re: Shared memory hogs
Posted in 1999
>Hi. Ever since upgrading to 7.30.UC6 on my HP9000 (HPUX 10.20) I find
that
>on occasion one instance will, on occasion, begin allocating shared
memory
>segments until it runs out of all available memory. At that point I
get
>the expected "could not allocate" errors in the message log. Nothing,
>including applications, general usage, onconfig, OS, or hardware
>configuration, has changed except for the version of Informix. (And
no,
>going back is not an option at this point.)
>
>After experiencing this on at least one occasion, onmode -F failed to
free
>them even when there were no users other than Informix on the system.
Most
>often the command works OK. Tech support tells me that there is
nothing in
>the problem tracking database, and certainly nothing in the bugs that
would
>account for this behaviour.
>
>Has anybody else seen this, or (better still) seen this, found a
>resolution, and been able to move forward? This is so intermittant
that it
>is hard to pin to a causal event, but it is a production database that
I
>can ill afford to be taking from the users on a regular basis. Also,
this
>is but one instance (of this version of Informix) of three on the same
>computer, and the other two do NOT experience this type of problem.
Mmmmm....this _looks_ a lot like the 7.2x problem where certain queries
combined with OPTCOMPIND=2 would cause the server to allocate far more
virtual memory than it needed, which would never get freed. And that was
on HPUX. Is OPTCOMPIND set to 2 on your box, and can you try setting it
to 0?
Just a guess, but I hope it helps. :-)
--
"I'll Be Back"
Obnoxio
************************************************
Sane? Hell, if I was sane, why would I be here?
Get Your Private, Free Email at http://www.hotmail.com