error syscdcv1 CDC_ERROR_CODE = -83717
Posted in 2013
Topics: Platform-Specific Issues, Versions, Editions & End-of-Life
Machine Configuration.... OS Name Linux OS Release 2.6.18-348.12.1.el5 OS Node Name wldbt635 OS Version #1 SMP Mon Jul 1 17:54:12 EDT 2013 OS Machine x86_64 IBM Informix Dynamic Server Version 11.50.UC9 Software Serial Number AAA#B000000 we are using a product dbmoto to connect the informix syscdcv1 datbase getting the error Tue Sep 17 12:22:02 CDC_ERROR_CODE = -83717 (UNKNOWN) (Unknown/Undocumented CDC API Error). Error calling cdc_startcapture(user_admin_accept:informix.ec_prov_people,e_person_id,i_person_ id,organ_id,person_title,initials,first_name,surname,surname_first,job_title,qua ls,attention,phone_ddi,phone_bus,phone_cell,phone_home,pager,fax_1,fax_2,email,s ex,contact_method,web_access,ppostal_addr,pactual_addr,pcourier_addr,pcity,pstat e,pcountry_id,address_flag,sound_ex,signature,seal_no,designation,create_date,cr eate_user,update_date,update_user,approve_date,approve_user,approved,imported) Tue Sep 17 12:22:02 does anyone know wht it means. This used to work ok when dbs were on HP UX now we have migrated to LINUX we get the problem.
Original post: Machine Configuration.... OS Name Linux OS Release 2.6.18-348.12.1.el5 OS Node Name wldbt635 OS Version #1 SMP Mon Jul 1 17:54:12 EDT 2013 OS Machine x86_64 IBM Informix Dynamic Server Version 11.50.UC9 Software Serial Number AAA#B000000 we are using a product dbmoto to connect the informix syscdcv1 datbase getting the error Tue Sep 17 12:22:02 CDC_ERROR_CODE = -83717 (UNKNOWN) (Unknown/Undocumented CDC API Error). Error calling cdc_startcapture(user_admin_accept:informix.ec_prov_people,e_person_id,i_person_ id,organ_id,person_title,initials,first_name,surname,surname_first,job_title,qua ls,attention,phone_ddi,phone_bus,phone_cell,phone_home,pager,fax_1,fax_2,email,s ex,contact_method,web_access,ppostal_addr,pactual_addr,pcourier_addr,pcity,pstat e,pcountry_id,address_flag,sound_ex,signature,seal_no,designation,create_date,cr eate_user,update_date,update_user,approve_date,approve_user,approved,imported) Tue Sep 17 12:22:02 does anyone know wht it means. This used to work ok when dbs were on HP UX now we have migrated to LINUX we get the problem. Response: Well, it looks like in the server code that -83717 would be returned if one of the columns you are trying to capture was a "Simple Blob" type (so of type text or byte I believe). I did go find in the change data capture api doc that it does mention that simple blob types are not supported (so you can't capture byte/text fields), so it would seem the 2 possibilities would be, 1) one of the columns listed above type was changed to a text/blob so now it won't work, or 2) the error being reported is incorrect and there might be some other problem. If it turns out to not be item 1, I'd probably suggest opening a pmr. Jacques Renaut IBM Informix Advanced Support APD Team
thanks for that Jacques text field is the problem
Out-Of-Row objects have to be retrieved directly. CDC returns the loca= tor and/or the rest of the row. Once you have captured the remainder of th= e row, the out-of-row data must be retrieved via normal SQL. = From: "KARL OLIVER" <karl.oliver@maf.govt.nz> = = To: ids@iiug.org, = = Date: 09/19/2013 04:21 PM = = Subject: Re: error syscdcv1 CDC_ERROR_CODE =3D -83717 [31465] = = Sent by: ids-bounces@iiug.org = = thanks for that Jacques text field is the problem ***********************************************************************= ******** Forum Note: Use "Reply" to post a response in the discussion forum. =