Re: Informix license branding.
Posted in 1998
Jonathan Leffler said
>John Grover wrote:
>>
>> We have an old version of Informix SE for SCO Unix. It's actually
>> running on a Linux box with IBCS installed, which we wish to upgrade to
>> a new box and a newer version of Linux. We no longer can locate the
>> installation media, or the license keys so we tried a direct copy of
>> the software to the new box, but it won't run.
>>
>> When I try to run isql, I get the following error:
>> 408: Invalid message type received from the sqlexec process>>
>> The sqlexec process, in fact, aborts with a segmentation fault.
>>
>> Can someone confirm or deny if this behavior is due to licensing? I'm
>> also open to speculations of what it might be.
>
>I don't think that is a licensing problem -- it is more fundamental
>than that. You get an error message when the product recognizes it
>isn't licensed. It sounds like the SCO Unix compatability on Linux
>isn't perfect...
Invalid message type normally means the sqlexec backend has
disappeared unexpectedly. This generally happens when upgrading
a RedHat installation because RedHat seem to just chuck iBCS
into their distribution with no real explanation or support.
iBCS is a *kernel module*. When the kernel is upgraded iBCS
should be expected to fail unless you get the latest from
tsx-11.mit.edu:/pub/linux/BETA/ibcs2/ and recompile it against
the kernel you run. Odds are that this is a kernel upgrade
from <=2.0.30 to >2.0.30 without the corresponding iBCS upgrade.
Mike
--
.----------------------------------------------------------------------.
| Mike Jagdis | Internet: mailto:mike@roan.co.uk |
| Roan Technology Ltd. | |
| 54A Peach Street, Wokingham | Telephone: +44 118 989 0403 |