HPL run job error
Posted in 2009
Topics: Migration, Import/Export & Data Conversion, Platform-Specific Issues, Versions, Editions & End-of-Life
Hello,
I'm working with IDS 9.40.FC7 on a Sun Solaris 8.
I have an issue with HPL when trying to run a job. I can create the job
successfully but I cannot run it.
The commands I'm using are :
$ onpladm create job expTst1Job -d expTst1File -D db1 -t my_tab -fuSuccessfully created Job expTst1Job
$ onpladm run job expTst1Job -fu
Connecting to onpload, Please wait...Timeout error trying to connect to onpload
....
Error: Onpload must run on the host (xxxx) that contains the target database.
Please advice me what I have to check/correct in my environment to be able to
run my unload job.
Thank you,
Elena
Hi Elena
The onpload utility expects that a job is executed on the same machine
where the load or unload job was created. That machine name is listed
in the onpload session table entry for that job, in the hostname field.
Onpload uses the machine name listed in the sqlhosts file for the
INFORMIXSERVER in effect at the time the job is created in the onpload
session table.
Prior to executing the job, onpload compares the hostname in the session table
job definition with the machine names in the UNIX /etc/hosts file. If
it does not find the name in /etc/hosts, onpload does not execute the
job and returns the target database error.
The machine name,
aliases and names associated with additional network cards found in the
/etc/hosts file are accepted by onpload. See the article referenced
below under Related information.
Regards,
----- Original Message ----
From: Elena Nemtisor <elena.nemtisor@softnet.ro>
To: ids@iiug.org
Sent: Mon, November 9, 2009 7:54:35 AM
Subject: HPL run job error [18004]
Hello,
I'm working with IDS 9.40.FC7 on a Sun Solaris 8.
I have an issue with HPL when trying to run a job. I can create the job
successfully but I cannot run it.
The commands I'm using are :
$ onpladm create job expTst1Job -d expTst1File -D db1 -t my_tab -fuSuccessfully created Job expTst1Job
$ onpladm run job expTst1Job -fu
Connecting to onpload, Please wait...Timeout error trying to connect to onpload
.....
Error: Onpload must run on the host (xxxx) that contains the target database.
Please advice me what I have to check/correct in my environment to be able to
run my unload job.
Thank you,
Elena
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.