DBimport error 212 106
Posted in 2004
We tried a dbimport and received the following errors.
Any ideas how to correct ?
$ finderr 212-212 Cannot add index.
This statement attempts to add an index, either explicitly with CREATE
INDEX or implicitly as part of processing a SELECT on multiple
unindexed tables. In any case, some error prevents the index from being
created. For more information, check the accompanying ISAM error code.
Insufficient disk space is a common cause of this problem.
$ finderr 106
-106 ISAM error: non-exclusive access.
The ISAM processor has been asked to add or drop an index but it does
not have exclusive access. For C-ISAM programs, the file must be opened
with exclusive access before you perform this operation. Review the
program logic, and make sure that it opens this file by passing the
ISEXCLLOCK flag to isopen. For SQL products, the database server
returns this error when an exclusive lock is required on a table. For
example, this error appears when a second user tries to alter a table
that the first user has locked.