Re: ISM restore to different machine
Posted in 2005
Hi,
please check if you did all steps described in 'IBM Informix Storage Manager
Administrator's Guide' chapter 'Transferring Data with the Imported Restore'.
If you get an error like
nsrmm: error, file disk data1 not in media index
when running the ism_op-mount command on the target machine then run
'ism_catalog -recreate_from' command for each of your devices befor.
Andreas
On Wednesday 21 September 2005 21:58, malcolm weallans wrote:
> IDS 9.40 on Suse Linux SLES8.
>
> We backup IDS to disk using onbar and ISM. We then backup the whole Linux
> disk using cpio. And we have recovered this configuration to the same
> physical machine in the past. We are now trying to "clone" the machine for
> further development purposes. We restored all of the informix directories
> and the ISM backup directories. We then created the appropriate devices
> for ISM, and mounted them. So far so good. We started up ism and asked
> ism_catalog to find_bootstrap on the device. It failed to find a
> bootstrap. It did manage to recover the save set info though.
>
> Does anybody have any idea as to the contents of the bootstrap?
>
> Needless to say that - as usual - the development project haven't allowed
> us much time to do this "delicate" operation.
>
> And BTW - we did have propblems with ism_startup but we solved those by
> unsetting the PRINTER environment variable and by installing the c
> compiler. It's interesting that ism needs those facilities to run on Linux.
> I Live and Learn.
>
> Malcolm
> sending to informix-list
sending to informix-list