Stored procedures on replication database
Posted in 2008
Hi All,
I run into the following problem:
We are running a HDR informix 10.00FC6 server and have created some
procedures. It appears that a user with connect access to the database can
execute this procedure on the primary database with no problem. However
running the same procedure on the replication database fails with error
message:
674: Routine (<routine_name>) can not be resolved.
When the same user is granted dba access the execution of the procedure on the
replication database is OK.
I have checked the access rights on the procedure and this is public on both
primary and replication (as should be).
Why should one have dba rights to execute procedures on a replication database
while for the primary database connect is sufficient?
Thanks,
Regards,
Bart