RE: Replication failure Q
Posted in 2009
I think I have a idea. My IBM support person Rashmi spotted from an oncheck
-pr that the rootdbs restore (onto the secondary) has the status of the
primary server as it was backed up (level 0). So when it is restored the
rootdbs says, as it should, it is the primary server. So this needs to be
cleaned up before proceeding with the oninit and restore. So my thinking is
that 11.10fc2W5 has a bug that does not fix this information up before it
continues. So how do it fix this?
For now the primary is standard so I will do another backup and restore that
to see what happens. If I am correct the restore might work. Then I can turn
on HDR again.
Problem! Since I can not make the secondary standard without first making
the primary standard, the HDR secondary will not work if the primary goes
down hard!
So I have a system where I can not use the secondary.
By the way, the 11.10 admin guide has had quite a bit of a re-write in the
HDR stuff and I think those that did it did a bang up job! Thanks...
,,,Tim
Tim Ertl
413-442-9000 x6211
This email was sent with Microsoft Outlook. If you see a winmail.dat or have
problems reading this email please let me know and I will resend using a RFC
compliant mail program.
Thanks,,,Tim
-----Original Message-----
From: Tim Ertl [mailto:tim@lmrgroup.com]
Sent: Saturday, March 28, 2009 14:36
To: 'ids@iiug.org'
Subject: RE: Replication failure Q
Well the water rises. Now while both servers are in standard mode I want to
benchmark the new disk drive with a point in time restore to get some data
that caused us a problem before and I come to a new problem! Informix will
not let me restore!
It gets past the roodbs than tries to start Informix BUT it tries to connect
to itself as the secondary and all the restores are not done yet!!!!
We were working fine until fc2W5 was installed. We used to work fine on
plain 11.10fc2.
So now I can't get my secondary back online! Since fc2W5 patches have
smashed my HDR can anyone say if 11.50 works HDR any better? Which patch
level is the best with HDR? I can't back off W5 since one of my tables
causes plan fc2 to assert itself.
I have used HDR very successfully since 1994. It was very straight forward
and easy to understand. I don't see why an onbar -r -p would even try to
connect to a secondary server much less itself? (It was the secondary before
I went standard).
1) onmode -d standard on the secondary no longer works! What happens if this
were a real disaster? I need my secondary to come online as standard!
2) after doing an onmode -d standard on the primary I was able to do a
onmode -d standard on the secondary.BOTH servers were in standard mode.
I put in the new disk drive...
3) onbar -r -p on the secondary fails due to the initialization wanting to
connect to a secondary server (itself).
4) DRAUTO=0 due some things I did not like about Auto failover in an earlier
release.
Looks like DRAUTO=0 is tried to do some sort of Automatic recovery or
something.
So I am currently stuck not being able to restore to the secondary. I hope
the primary stays up!
,,,Tim
Tim Ertl
413-442-9000 x6211
This email was sent with Microsoft Outlook. If you see a winmail.dat or have
problems reading this email please let me know and I will resend using a RFC
compliant mail program.
Thanks,,,Tim
-----Original Message-----
From: Tim Ertl [mailto:tim@lmrgroup.com]
Sent: Saturday, March 28, 2009 10:57
To: 'ids@iiug.org'
Subject: Replication failure Q
I just discovered that IDS 11.10 replication has a significantly different
operational feature than the old 9 days. In particular when the PRIMARY
fails we used to be able to issue an "onmode -d standard" to put the
secondary into production. We have done this a number of times on 9.3.
When we installed 11.10 we can not longer do this. We get a messages after
doing the Onmode -d standard (on secondary) saying:
DR: Unable to change server type
In the online log I see:
DR: DR should be turned off for secondary to standard change.
This message is amusing since I think onmode -d standard is how you turn off
replication. At least in the past.
Today I researched and played. I see the onmode -d operations for the
secondary's. Then I discovered that I can do the onmode -d standard on the
Primary and THEN do the onmode -d standard on the secondary. But that is
pretty much useless in the event of a real hardware failure on the primary.
I do not see any new "turn off replication" commands but I see a mess of
other new commands for RSS and other fun stuff. How do I promote the
secondary into standard mode if the primary is down? The 11.10 manual seems
to imply about the same thing as the 9.3 manual so I am confused.
If no-one has any ideas I will report this next week to Informix Support as
a possible bug.
IDS 11.10fc1W5+ on Sun Solaris 10.
Thanks,,,
,,,Tim
Tim Ertl
413-442-9000 x6211
This email was sent with Microsoft Outlook. If you see a winmail.dat or have
problems reading this email please let me know and I will resend using a RFC
compliant mail program.
Thanks,,,Tim