RE: Help Loading table from flat file.
Posted in 1997
Hi Ernie!
This is the description of error -847:
Error in load file line number.=20
A problem exists with the data on the indicated line of the load data =
file. The operation stopped after it inserted lines up to but not =
including the line that is noted (number-1 rows have been inserted). If =
this operation is inside a transaction, roll back the transaction. If =
not, either delete the inserted rows from the table or remove the used =
lines from the file before you repeat the operation. To correct the =
file, look for additional error messages that might help isolate the =
problem. Possibly not enough, or too many, fields (delimiters) exist on =
the indicated line. Possibly a data conversion problem exists, (for =
example, nonnumeric characters in a numeric field, an improperly =
formatted DATETIME value, or a character string that is too long). =
Possibly a null (zero-length) field exists in a column where nulls are =
not allowed. Edit the load file to correct the problem. Look for similar =
problems in following lines, and then repeat the operation.
Try to use dbload command line, it has an option to skip errors and =
place them in a log
file.
The -r option instructs dbload not to lock the table(s) during loading
The -n num-rows , instructs dbload to execute a commit after the =
specified number of new
rows are inserted. (Works only if your =
database has logging, if you don=B4t
specify it the default value is 100)
The -e num-rows, specifies the number of bad rows that dbload will =
read before terminating
The -l errorfile , specifies the name and location of the error =
log.
With these options you will be able to accomplish your task.
Regards,
Mario Estrada
----------------Reply Separator-------------
----------
From: Ernie Graeler[SMTP:ernieg@hiway1.exit109.com]
Sent: Martes 6 de Mayo de 1997 01:31 PM
To: informix-list@rmy.emory.edu
Subject: Help Loading table from flat file.
I am currently trying to move the contents of a table from one database
to another. The way I am doing this is I've created a duplicate of the =
table=20
in database1 in database2 then I unloaded the table from database1 into =
a
flat file. Then I plan on loading the flat file into the table in =
database2.
The problem I am having is this: The load from the flat file into the =
table=20
on database2 fails with the following error:=20
847: Error in load file line 862.The line number changes every time I try. I looked at the file, but =
don't see
any problems. The table has 1852 rows and is over 5MB in size. I split =
the file
up into 4 flat files. When I loaded from the 4 flat files, everything =
worked=20
and loaded OK. I see this as a problem. Informix should be able to =
handle a=20
5MB file of 1852 rows. Could it be a configuration setting? I'm running =
On-Line Dynamic Server Version 7.2. Any Ideas out there?
Thanks in advance,
Ernst Graeler egraeler@commvault.com
--
Ernst F. Graeler =20
+----------------------------------------------+
| You from Joisey!? ...Yeah I'm from Joisey!!! |
| Oh Yeah! What Exit? ernieg@exit109.com |
+----------------------------------------------+