RE: HDR initial setup question
Posted in 2003
I have used this method several times,
but instead of using onbar, i use ontape.
But i think that there is no main difference in
the procedure and by my experience on troubleshooting
it, i could tell you that your problem may be caused
by one of three main reasons :
1. you are not transfering the backup-file on binary
mode :
ftp> bin
200 Type set to I (Image/Binary).
2. There is a problem on your network that makes the
transfer fail. Check the "Transfer Complete" message
when finishing the transfer and verify the size of the
transfered file (it has to be identical).
3. Believe me, it can happen : You forgot to take informix
down before restoring the backup on the secondary server .
If none of these 3 reasons is the cause of your problem,
i suggest you to use ontape -s -L 0 instead of onbar and do
the same transfering procedure via ftp.
Another approach is to use a shared store device between both servers:
_ shared array,
_ another server's hard disk mapped via Network File System-NFS
I hope this helps you.
Let me know if you solve your problem
Regards
-----Mensaje original-----
De: Josh Marshall [mailto:josh@worldhosting.org]
Enviado el: Martes, 30 de Septiembre de 2003 10:51 p.m.
Para: informix-list@iiug.org
Asunto: HDR initial setup question
Hi,
I've been trying to get a pair of servers to work in HDR (High Availability
Data Replication) mode - but am having some problems getting them to be
identical in the first place. I have followed the documentation in the Admin
guide to configure the two servers to be identical in the areas that matter
(I wasn't sure whether the name had to be the same or not... does it?)
The documentation states that I "simply" onbar -b -L 0 on the primary then
onbar -r -p on the secondary.
Neither server has a tape so I have to use the hard disk, and I assume ftp
the
files to the secondary.
I have followed a couple of howto's but am unable to work out how to restore
the secondary. The closest I get gives me the following error after copying
across the files created by onbar, the ixbar file and the /nsr/mm and
/nsr/index folders:
----8<----
2003-09-30 23:55:01 12321 12319 /opt/informix/bin/onbar_d -r -p
2003-09-30 23:55:01 12321 12319 Successfully connected to Storage Manager.
2003-09-30 23:55:01 12321 12319 XBSA Error: (BSAGetObject) Backup object
does not exist in Storage Manager.
2003-09-30 23:55:01 12321 12319 Object information: bar_objdesc
obj_id 0 obj_name 'rootdbs' obj_type 'R' act_id 0 act_type 2 act_status
0
act_start '2003-09-30 23:55:01' act_end '2003-10-01 11:24:11'
ins_time 0 rsam_time 0 level 0 copyid hi:lo 31447:0 req_act_id 19
logstream 0 est_pages hi:lo 0:0 first_log 0 chpt_log 0 last_log 0
partial_flag 0 do_query 0 ins_sm_id 0 ins_sm_name ''
ins_verify 0 ins_verify_date '' restore order 0:0
objInfo ''
retry 0 in_catalog 0 in_bootfile 0 child_pid 0 child_state 0
bkup_host ''
2003-09-30 23:55:01 12321 12319 ON-Bar was unable to get backup record of
rootdbs from storage manager.
2003-09-30 23:55:01 12321 12319 Due to the previous error, logical restore
will not be attempted.
2003-09-30 23:55:01 12321 12319 /opt/informix/bin/onbar_d complete,
returning 100 (0x64)
----8<----
I'm hoping someone can point me to a good way to do this. I had a thought
that
maybe I could get the secondary server to connect to the ISM on the primary
server (seeing "bkup_host" in the bar_act log) - but found no way to do
this.
Thanks in advance,
Josh.
sending to informix-list
sending to informix-list