IDS crashed when you run ontape backup
Posted in 2012
Topics: Backup & Restore, Error Codes & Troubleshooting
UNIX: Tru64 Version 5.1a
IDS: IBM Informix Dynamic Server Version 9.40.FC9
When I run ontape I receive following error and Informix crash.
11:59:48 shmat: [12]: operating system error
11:59:48 Client could not attach server shared memory segment, use IFX_XFER_SHM
BASE.
11:59:48 shmat: [12]: operating system error
11:59:48 Client could not attach server shared memory segment, use IFX_XFER_SHM
BASE.
11:59:48 shmat: [12]: operating system error
11:59:48 Client could not attach server shared memory segment, use
IFX_XFER_SHMBASE.
11:59:48 Assert Failed: errors occurred during mt_notifyvp
11:59:48 IBM Informix Dynamic Server Version 9.40.FC9
11:59:48 Who: Session(28, root@DS25.pascoccc.local, 34180, 200b14530)
Thread(166, ontape, 200ad7e00, 1)
File: mt.c Line: 11201
11:59:48 stack trace for pid 9296 written to /tmp/af.48ee5f4
11:59:48 See Also: /tmp/af.48ee5f4, shmem.48ee5f4.0
11:59:54 mt.c, line 11201, thread 166, proc id 9296, errors occurred during
mt_notifyvp.
11:59:54 The Master Daemon Died
11:59:54 PANIC: Attempting to bring system down
DS25># onstat -g seg
IBM Informix Dynamic Server Version 9.40.FC9 -- On-Line -- Up 00:19:37 -- 57344 Kbytes
Segment Summary:
id key addr size ovhd class blkused blkfree
4096 1381386241 200000000 8388608 424000 R* 1596 452
4097 1381386242 200800000 41943040 1832 V 6305 3935
4098 1381386243 203000000 8388608 808 M 1231 817
Total: - - 58720256 - - 9132 5204
(* segment locked in memory)
Thank you
Kanti
Informix 9.40 is out-of-support, so there will be no new bug fixes. If you
are on continuing support, then if there is a later release of 9.40 that
has a fix for this, you can get it, otherwise....
I would use dbexport to create a safety export of each of your databases to
flat files as soon as it is practical (dbexport locks the database in 9.40
so it will have to be during sometime when you can get all users offline).
If you can't get everyone offline, you can use my dbexport replacement
utility, myexport, to create these flat file backups without locking.
Art
Art S. Kagel
Advanced DataTools (www.advancedatatools.com)
Blog: http://informix-myview.blogspot.com/
Disclaimer: Please keep in mind that my own opinions are my own opinions
and do not reflect on my employer, Advanced DataTools, the IIUG, nor any
other organization with which I am associated either explicitly,
implicitly, or by inference. Neither do those opinions reflect those of
other individuals affiliated with any entity with which I am affiliated nor
those of the entities themselves.
On Thu, May 10, 2012 at 12:26 PM, KANTI BAKARANIA <kbakarania@pascoclerk.com
> wrote:
> UNIX: Tru64 Version 5.1a
>
> IDS: IBM Informix Dynamic Server Version 9.40.FC9
>
> When I run ontape I receive following error and Informix crash.
>
> 11:59:48 shmat: [12]: operating system error
> 11:59:48 Client could not attach server shared memory segment, use
> IFX_XFER_SHM
> BASE.
> 11:59:48 shmat: [12]: operating system error
> 11:59:48 Client could not attach server shared memory segment, use
> IFX_XFER_SHM
> BASE.
> 11:59:48 shmat: [12]: operating system error
> 11:59:48 Client could not attach server shared memory segment, use
> IFX_XFER_SHMBASE.
> 11:59:48 Assert Failed: errors occurred during mt_notifyvp
> 11:59:48 IBM Informix Dynamic Server Version 9.40.FC9
> 11:59:48 Who: Session(28, root@DS25.pascoccc.local, 34180, 200b14530)
>
> Thread(166, ontape, 200ad7e00, 1)
>
> File: mt.c Line: 11201
> 11:59:48 stack trace for pid 9296 written to /tmp/af.48ee5f4
> 11:59:48 See Also: /tmp/af.48ee5f4, shmem.48ee5f4.0
> 11:59:54 mt.c, line 11201, thread 166, proc id 9296, errors occurred during
> mt_notifyvp.
> 11:59:54 The Master Daemon Died
> 11:59:54 PANIC: Attempting to bring system down
>
> DS25># onstat -g seg
>
> IBM Informix Dynamic Server Version 9.40.FC9 -- On-Line -- Up 00:19:37 --> 57
> 344 Kbytes
>
> Segment Summary:
> id key addr size ovhd class blkused blkfree
> 4096 1381386241 200000000 8388608 424000 R* 1596 452
> 4097 1381386242 200800000 41943040 1832 V 6305 3935
> 4098 1381386243 203000000 8388608 808 M 1231 817
> Total: - - 58720256 - - 9132 5204
>
> (* segment locked in memory)
>
> Thank you
>
> Kanti
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--14dae9340e21077c4004bfb12acb
From the best I can recall this sounds like an old defect with ontape; when
you try to take an archive and the total size of your allocated shared memory
(onstat -g seg) is greater than 2 gig (or slightly greater )this error will
occur . (ontape is separate binary from the engine so it doesn't matter if the
engine is 64 bit). So a workaround you can try to restart the engine with a
small memory footprint (< 2 gig) and take the level 0. If it works then thats
the root cause, but you better think about upgrading in any event since sooner
or later you will need TS.
Related threads
- Posting from the Informix-list
- Migrating from IDS 9.40.UC6 to 11.50.UC3
- Ip for a network session
- questions onstat -g