Re: unable to initialize database
Posted in 1999
> Im am running DS on a Linux-computer. A database with several tables works
> fine over a period of several months. Yesterday I tried to completely rebuild
> the server. I tried "oninit -i" after I have restarted the computer. But
> oninit shows the error-message "Fatal error in shared memory initialization".
> There is no difference (within the config-files) between the first
> initialization (some months ago) and the new try.
I know you said there are no differences between the onconfig files, but I have to
ask anyway - what is the value of PHYSDBS? If you moved your physical log to a new
dbspace (as is recommended), and PHYSDBS still points to that other dbspace, you'll
get the message you received. It's misleading, but is caused by the fact that the
engine only know of one dbspace (rootdbs) when you do 'oninit -i'. If that's not
the problem, try 'oninit -iv' to get verbose output that may help pinpoint the
problem.
Mark Collins
mcollins@us.dhl.com