Re: ovlock=56
Posted in 1997
In article <TnxB1BAetdhzEwNU@smooth1.demon.co.uk>, David Williams <djw@smooth1.demon.co.uk> wrote: >In article <5m39a2$nfu@camel1.mindspring.com>, Larry Foote ><lfoote@pipeline.com> writes >>ogolde@impsat1.com.ar (Oscar Goldes) wrote: <snip> >>>The value of LOCKS is 60000 >>>What happens when a process needs a lock and there are no more available? > The update/insert/delete/select FAILS and an error code is returned to >the apllication. > >>I suggest bumping locks up to at least 200000. It takes a little more > 1 lock = ~43 bytes therefore 10,000 locks = roughly 1/2 Mb of memory. > > Since you are only getting occasional ovlocks I would try 100,000 >locks i.e. increase memory usage by 40,000 locks = 2Mb. If you still >get ovlocks then kep increasing by 40,000 until they stop happening. > I think that, besides (or before!) increasing locks (as an immediate corrective measure), you need to examine the source of the problem. Your message log file will give you some clues. For example, if most of the ovlocks are clustered (look for "Lock table overflow" messages), there could be a 'rogue' application which needs to be looked into - typically batch updates/loads whose transaction handling can be improved. (The next time a user complains about being 'thrown out' or you see the errors on your console, examine the apps running for the culprit) On the other hand, if the ovlock errors are spread out, increasing LOCKS may be all you have to do. Of course, if you do increase LOCKS and the problem 'goes away', you may not be able to identify the possible rogue, so if your users are not raising merry hell, you could stay at LOCKS=60000 to identify the possible culprit. HTH. ---------------------- Rudy Fernandes GIC, Kuwait OL 7.20, 4Gl 6.04 ----------------------