ISAM error: illegal key descriptor (too many parts
Posted in 2013
IDS 11.50 FC2
HP UX 11.23
Noticed below errors while running onchecks on a couple of databases. Dropped
and re-created the indexe. Would like to know the cause for these bad index
pages. Data in these tables are 10 years old. HP confirmed no hardware issue.
Everything seems to be working fine for few years and then we come up with
these bad pages.
Had a crash with one of the primary chunks going offline couple of weeks back
but again could not identify the issue based on the stack files.
Validating database dbew48
Validating systables for database dbew48
ISAM error: illegal key descriptor (too many parts or too long).
TBLspace name wq_hist_t
Owner informix
TBLspace number 40065a
Tabid 185
Row size 40
Number of columns 8
Number of indexes 4
Number of rows 1098290215
Date created 09/09/2012
TBLspace major version number 189
TBLspace minor version number 1514
TBLspace type T
Locking level R
Number of pages used 1092619864
First extent size 4386448
Next extent size 731074
Flags 0
Site
Database name
Validating syscolumns for database dbew48
Validating sysindexes for database dbew48
ISAM error: illegal key descriptor (too many parts or too long).
Validating indexes for dbew48:informix.wq_hist_t...
Index wq_hist_x01n
ERROR: Bad key information in TBLspace description.
ERROR: Index wq_hist_x01n for dbew48:informix.wq_hist_t is bad.