Error with XA transactions
Posted in 2011
Topics: Server Administration, Licensing & Editions
Hi All,
Hope someone familiar with XA transaction setup via WebSphere can
provide me some answers.
We recently switched from Connection Pooling to XA transactions via
WebSphere, connecting to some Informix 9.40 databases.
We started receiving SQL Exception error messages "The database server
is not licensed for distributed data access".
Investigation showed a table in the database that was actually a
synonym table linking to a different instance on a separate server.
When trying to Insert into that table, the error popped up.
(Using dbaccess to insert the row works just fine, so we know the
servers are talking).
Switching the connection back to Pooling allows the transaction to
complete correctly.
The XA transactions work fine while using the main server, but when
accessing the synonym table, they fail.
Any ideas what settings need to be in order for "distributed"
transactions to work?
Thanks!
Michael Hoffman
We have seen the same problem on 11.50. As I understand it the error message is incorrect, I think the problem is that the server can't handle XA transactions on synonyms. This is understandable, but not documentet and the error message does not help you. We are Weblogic not WebSphere, I don't think that the problem is in the TM but in the databaserver. Regards Ulf