on-Bar & ISM
Posted in 2005
Topics: Backup & Restore, Storage & Space Management
I have successfully set up On-Bar & ISM on my brand
new test server.
I am now experiencing problems migrating my development server from On-Archive
to On-Bar; As far as I can see both machines are configured the same.
I was previously getting the following error in the bar_act.log
XBSA Error: (BSACreateObject): A system error occured. Aborting XBSA session
and in xbsa.messages
_nwbsa_is_retryable_error: received a network error (Severity 5 Number 13):
`hps03.hmgcc' is not a registered client.
This was resolved by my Unix Administrastor defining hps03.hmgcc as an alias
in Legato running on another server.
Now When I run onbar -b I get
NetWorker: RPC error, Unable to send
NetWorker: Send Chunk to MMD failed, Broken pipe
online.log shows that the archive has aborted on some dbspaces
Level 0 Archive started on projectdbs
Archive on projectdbs ABORTED
bar_act.log shows
Process 27396 received signal 13. Process will exit after cleanup.
The On-Bar process 27396 exited with a problem (exit code 141(0x8d), signal 0).
xbsa.messages shows
_nwbsa_close_create_object_session: BSA_RC_ABORT_SYSTEM_ERROR System detected
error due to savefile_fini() failure. Operation aborted.
Some dbspaces and blobspaces are backed up and some are not.
Can anyone help me ?
Hi,
hmm. I'm not sure what's happening on your machine.
ISM is only good for local operation. You cannot use it
to put the backup data on a remote machine. The ISM
must be running locally on the same machine as the IDS
server.
Have you checked that you are using the proper XBSA
library ? Check BAR_BSALIB_PATH parameter setting
in your $ONCONFIG file. It should be something like
$INFORMIXDIR/lib/libbase.so where you have to
replace $INFORMIXDIR with whatever its setting is on
your system.
This is what I can currently think of.
Regards,
Martin
--
Martin Fuerderer
IBM Informix Development Munich, Germany
Information Management
forum.subscriber@iiug.org wrote on 19.01.2005 16:50:04:
> I have successfully set up On-Bar & ISM on my brand new test server.
> I am now experiencing problems migrating my development server from
> On-Archive to On-Bar; As far as I can see both machines are configured
the same.
>
> I was previously getting the following error in the bar_act.log
>
> XBSA Error: (BSACreateObject): A system error occured. Aborting XBSA
session
>
> and in xbsa.messages
>
> _nwbsa_is_retryable_error: received a network error (Severity 5 Number
13):
> `hps03.hmgcc' is not a registered client.
>
> This was resolved by my Unix Administrastor defining hps03.hmgcc as an
> alias in Legato running on another server.
>
> Now When I run onbar -b I get
>
> NetWorker: RPC error, Unable to send
> NetWorker: Send Chunk to MMD failed, Broken pipe
>
> online.log shows that the archive has aborted on some dbspaces
>
> Level 0 Archive started on projectdbs
> Archive on projectdbs ABORTED
>
> bar_act.log shows
>
> Process 27396 received signal 13. Process will exit after cleanup.
> The On-Bar process 27396 exited with a problem (exit code 141(0x8d),
signal 0).
>
> xbsa.messages shows
>
> _nwbsa_close_create_object_session: BSA_RC_ABORT_SYSTEM_ERROR System
> detected error due to savefile_fini() failure. Operation aborted.
>
> Some dbspaces and blobspaces are backed up and some are not.
>
>
> Can anyone help me ?
>
>
I have our system working on Solaris 8
Here are my parameter settings
BAR_ACT_LOG /export/home/informix/bar_act.log
BAR_DEBUG_LOG /export/home/informix/bar_dbug.log
BAR_MAX_BACKUP 1
BAR_RETRY 1
BAR_NB_XPORT_COUNT 10
BAR_XFER_BUF_SIZE 31
RESTARTABLE_RESTORE offLOG_BACKUP_MODE MANUAL # MANUAL - user must perform log backups
# NONE - don't backup logs and re-use them
# as soon as they fill.
##BAR_DEBUG 9 # Only for ONBAR debugging purposes
BAR_BSALIB_PATH /usr/lib/ibsad001.so # Full path name of storage manager
ISM_DATA_POOL ISMDiskData # ISM_DATA_POOL value
ISM_LOG_POOL ISMDiskLogs # ISM_LOG_POOL value
ALARMPROGRAM /export/home/informix/etc/log_full.sh # Alarm program path
I recommend using ISA 1.50 the latest version Web base tool that is free with
IDS. The GUI has a section on ISM to ease administration.
Make sure the ism daemon has started - ism_startup -init must be started under
root id.
I hope this helps
Carl Berner
---------- Forwarded Message ----------
Hi,
hmm. I'm not sure what's happening on your machine.
ISM is only good for local operation. You cannot use it
to put the backup data on a remote machine. The ISM
must be running locally on the same machine as the IDS
server.
Have you checked that you are using the proper XBSA
library ? Check BAR_BSALIB_PATH parameter setting
in your $ONCONFIG file. It should be something like
$INFORMIXDIR/lib/libbase.so where you have to
replace $INFORMIXDIR with whatever its setting is on
your system.
This is what I can currently think of.
Regards,
Martin
--
Martin Fuerderer
IBM Informix Development Munich, Germany
Information Management
forum.subscriber@iiug.org wrote on 19.01.2005 16:50:04:
> I have successfully set up On-Bar & ISM on my brand new test server.
> I am now experiencing problems migrating my development server from
> On-Archive to On-Bar; As far as I can see both machines are configured
the same.
>
> I was previously getting the following error in the bar_act.log
>
> XBSA Error: (BSACreateObject): A system error occured. Aborting XBSA
session
>
> and in xbsa.messages
>
> _nwbsa_is_retryable_error: received a network error (Severity 5 Number
13):
> `hps03.hmgcc' is not a registered client.
>
> This was resolved by my Unix Administrastor defining hps03.hmgcc as an
> alias in Legato running on another server.
>
> Now When I run onbar -b I get
>
> NetWorker: RPC error, Unable to send
> NetWorker: Send Chunk to MMD failed, Broken pipe
>
> online.log shows that the archive has aborted on some dbspaces
>
> Level 0 Archive started on projectdbs
> Archive on projectdbs ABORTED
>
> bar_act.log shows
>
> Process 27396 received signal 13. Process will exit after cleanup.
> The On-Bar process 27396 exited with a problem (exit code 141(0x8d),
signal 0).
>
> xbsa.messages shows
>
> _nwbsa_close_create_object_session: BSA_RC_ABORT_SYSTEM_ERROR System
> detected error due to savefile_fini() failure. Operation aborted.
>
> Some dbspaces and blobspaces are backed up and some are not.
>
>
> Can anyone help me ?
>
>