Re: ontape failure for DS 7.14.UC1
Posted in 1997
In article <5h63u4$hij@cssun.mathcs.emory.edu>, Tracy Nedd
<tracyn@asd.banctec.com> writes
>Hi,
>
>I've run across this problem with my temp dbspaces too. There are
>two solutions that I know of:
>
>1) Don't create your temp dbspaces as TEMP when you make them. You can
>still put non-TEMP dbspaces in the DBSPACETEMP env variable listing. Then
>the space will be backed up and restored just like the other dbspaces.
>
>2) Create a second symbolic link to the dbspace marked at inconsistent.
>Use this link to create another temp dbspace. You will still have the old
>unusable dbspace listed too, but now you can reuse the disk space again.
>
>Hope this helps
>
>Tracy
>}
>} } In article <33336F10.135@jps.net>, Don Wallom <dwallom@jps.net> writes
>} } >We are running DS 7.14.UC1 on HP-UX 10.01 for 6 months.
>} } >
>} } >We tried to recover our level 0 archive and it failed.
>} } >Informix tech support ran a tool on our level 0 archive tape
>} } >which showed a dbspace is missing (it showed as being backed up in
>} } >online.log)
>} } >
>} } >We have ontape configured as
>} } >
>} } >TAPEBLK 256 (in KB)
>} } >TAPESIZE 3950000 (in KB)
>} } >
>} } >Anyone else experienced this ???
>} } >
>} } >HELP !!!
>} } >
>} } >Don Wallom
>} } >DBA in distress
>} }
>} } Was it a temporary dbspace i.e. the flag 'T' was set on it?
>} } If so it will NOT be archived...
>} }
>} }
>} } --
>} } David Williams
>} }
>}
>} Hello,
>}
>} I am working on Online 7.13 UC1 HP-UX 9.04 and I experienced such a
>} problem (which is not yet solved).
>}
>} I restored a level 0 backup from tape and then the temporary chunk
>} tempdbs become inconsistent. I looked for it on my backup and noticed
>} that it was not on it.
>}
>} At the moment the chunk is still inconsistent and I cannot drop it
>} because onspaces command says that it does not exist but onstat -d shows
>} it oncheck -pr indicates that this chink is online.
>}
>} Of course if I try to create another one, onspaces tells that this
>} dbspace already exists !
>}
>} I don't know how to solve this problem, I didn't see anything about this
>} in documentation.
>}
>} If somebody knows anything about those problems please help us.
>} Regards.
>} Jean-Francois.
>}
>
I hit this problem at the end of last week, the solution was to
a) Shutdown Online.
b) Set DBSPACETEMP parameter to nothing in onconfig
c) unset DBSPACETEMP environment variable
d) start online
e) use onspaces -d tempdbs to delete the inconsistent dbspace.
(You will get a message about unable to delete)
f) shutdown and start online.
The tempdbs was gone and could now be recreated!!!
--
David Williams