HDR: Checkpoint Record not Found in Logical Log
Posted in 2008
Topics: High Availability & Replication, Backup & Restore, Error Codes & Troubleshooting, Server Administration, Logging & Checkpoints, Versions, Editions & End-of-Life
I am trying to re-enable HDR on a pair of machines that I have used it
successfully on in the past. Neither the configuration nor the hardware has
changed on either box.
After a clean restore using `ontape -p`, I restart the secondary server and
place it in recovery mode with `oninit -r`, then put both machines in HDR mode
using `onmode -d`. After about 1.5 minutes I get these message in the log of
the secondary:
----
08:49:19 DR: Failure recovery from disk in progress ...
08:49:20 Logical Recovery Started.
08:49:20 10 recovery worker threads will be started.
08:49:20 Start Logical Recovery - Start Log 14732, End Log ?
08:49:20 Starting Log Position - 14732 0xc79018
08:49:20 Clearing the physical and logical logs has started
08:50:44 Cleared 2087 MB of the physical and logical logs in 84 seconds
08:50:48 Checkpoint Record not Found in Logical Log.
08:50:48 Assert Failed: DR: Log Record Apply Thread Exited Abnormally.
Internal Error.
A restart of the database server shall be required to correct
this problem.
-----
This never used to happen when I set this up, which I have done three or four
times now. I am quite baffled. Any thought on what I can do to correct it?
For reference: system is IDS 10.00.U5 on AIX.
> -----Original Message-----
> From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of
> LANCE GALLOP
> Sent: Friday, March 14, 2008 8:14 AM
> To: ids@iiug.org
> Subject: HDR: Checkpoint Record not Found in Logical Log [11620]
>
> I am trying to re-enable HDR on a pair of machines that I have used it
> successfully on in the past. Neither the configuration nor the
hardware
> has
> changed on either box.
>
> After a clean restore using `ontape -p`, I restart the secondary
server
> and
> place it in recovery mode with `oninit -r`, then put both machines in
HDR
Go directly from ontape -p to onmode -d secondary my_primary_name
Do not pass GO, do not collect $200. And definitely don't onmode -yuk
or oninit (the manual says specifically that if you do, you have to redo
your ontape -p).
--EEM
> mode
> using `onmode -d`. After about 1.5 minutes I get these message in the
log
> of
> the secondary:
>
> ----
> 08:49:19 DR: Failure recovery from disk in progress ...
> 08:49:20 Logical Recovery Started.
> 08:49:20 10 recovery worker threads will be started.
> 08:49:20 Start Logical Recovery - Start Log 14732, End Log ?
> 08:49:20 Starting Log Position - 14732 0xc79018
> 08:49:20 Clearing the physical and logical logs has started
> 08:50:44 Cleared 2087 MB of the physical and logical logs in 84
seconds
> 08:50:48 Checkpoint Record not Found in Logical Log.
> 08:50:48 Assert Failed: DR: Log Record Apply Thread Exited Abnormally.
> Internal Error.
>
> A restart of the database server shall be required to correct
>
> this problem.
> -----
>
> This never used to happen when I set this up, which I have done three
or
> four
> times now. I am quite baffled. Any thought on what I can do to correct
it?
>
> For reference: system is IDS 10.00.U5 on AIX.
>
>
>
************************************************************************
**
> *****
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
> See you at the IIUG Informix 2008 Conference
> The Power Conference for Informix Professionals
> April 27 - 30, 2008 Marriott Overland Park (Kansas City), Kansas
> http://www.iiug.org/conf
> Registration Now Open!!
That did the trick. Thanks.