fatal error in shared memory initialization
Posted in 2010
Topics: High Availability & Replication, Security, Permissions & Auditing, Versions, Editions & End-of-Life
IDS 11.50.FC6 on SLES 11x64 on a XenCenter Citrix VM with 4gb of memory and 3
cpus.
When starting up informix I get the following:
11:17:34 IBM Informix Dynamic Server Started.
11:17:34 Segment locked: addr=0x44000000, size=623669248
11:17:34 Segment locked: addr=0x692c7000, size=402653184
11:17:35 Warning: pid 3133: cannot load NULL library name at address 0xf1cff000
11:17:35 Event alarms enabled. ALARMPROG = '/opt/informix/etc/alarmprogram.sh'
11:17:35 Booting Language <c> from module <>
11:17:35 Loading Module <CNULL>
11:17:35 Booting Language <builtin> from module <>
11:17:35 Loading Module <BUILTINNULL>
11:17:41 DR: DRAUTO is 0 (Off)
11:17:41 DR: ENCRYPT_HDR is 0 (HDR encryption Disabled)
11:17:41 Event notification facility epoll enabled.
11:17:41 IBM Informix Dynamic Server Version 11.50.FC6 Software Serial Number
AAA#B000000
11:17:42 IBM Informix Dynamic Server Initialized -- Shared Memory Initialized.
11:17:42 Physical Recovery Started at Page (1:262570).
11:17:42 Physical Recovery Complete: 0 Pages Examined, 0 Pages Restored.
11:17:42 Logical Recovery Started.
11:17:42 10 recovery worker threads will be started.
11:17:43 Logical Recovery has reached the transaction cleanup phase.
11:17:43 Logical Recovery Complete.
0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
11:17:44 oninit: Fatal error in shared memory initialization
11:17:44 IBM Informix Dynamic Server Stopped.
11:17:44 mt_shm_remove: WARNING: may not have removed all/correct segments
Here is the shared memory configuration:
RESIDENT -1
SHMBASE 0x44000000
SHMVIRTSIZE 393216
SHMADD 65536
EXTSHMADD 32768
SHMTOTAL 0
SHMVIRT_ALLOCSEG 0.000000
SHMNOACCESS M|
Thoughts?
Jonathon Wyza
CX & CBORD System Administrator
CX Programmer/Analyst
Administrative Computing
Bethel College
(574)-257-3381
AIM: Iamwyza
jonathon.wyza@bethelcollege.edu<mailto:jonathon.wyza@bethelcollege.edu>
==============================
SLES 11x64 & IDS 11.50.FC6
"Don't document the problem, fix it."
- Atli Björgvin Oddsson
You can run onclean command to ensure a clean environment. This will cl=
ean
up any shared memory segments that are required by the server, but migh=
t be
left over.
Regds,
Uday.
|------------>
| From: |
|------------>
>--------------------------------------------------------------------=
-----------------------------------------------------------------------=
-------|
|"Wyza, Jonathon" <wyzaj@bethelcollege.edu> =
=
|
>--------------------------------------------------------------------=
-----------------------------------------------------------------------=
-------|
|------------>
| To: |
|------------>
>--------------------------------------------------------------------=
-----------------------------------------------------------------------=
-------|
|ids@iiug.org =
=
|
>--------------------------------------------------------------------=
-----------------------------------------------------------------------=
-------|
|------------>
| Date: |
|------------>
>--------------------------------------------------------------------=
-----------------------------------------------------------------------=
-------|
|09/07/2010 10:25 AM =
=
|
>--------------------------------------------------------------------=
-----------------------------------------------------------------------=
-------|
|------------>
| Subject: |
|------------>
>--------------------------------------------------------------------=
-----------------------------------------------------------------------=
-------|
|fatal error in shared memory initialization [21189] =
=
|
>--------------------------------------------------------------------=
-----------------------------------------------------------------------=
-------|
|------------>
| Sent by: |
|------------>
>--------------------------------------------------------------------=
-----------------------------------------------------------------------=
-------|
|ids-bounces@iiug.org =
=
|
>--------------------------------------------------------------------=
-----------------------------------------------------------------------=
-------|
IDS 11.50.FC6 on SLES 11x64 on a XenCenter Citrix VM with 4gb of memory=
and
3
cpus.
When starting up informix I get the following:
11:17:34 IBM Informix Dynamic Server Started.
11:17:34 Segment locked: addr=3D0x44000000, size=3D623669248
11:17:34 Segment locked: addr=3D0x692c7000, size=3D402653184
11:17:35 Warning: pid 3133: cannot load NULL library name at address
0xf1cff000
11:17:35 Event alarms enabled. ALARMPROG =3D
'/opt/informix/etc/alarmprogram.sh'
11:17:35 Booting Language <c> from module <>
11:17:35 Loading Module <CNULL>
11:17:35 Booting Language <builtin> from module <>
11:17:35 Loading Module <BUILTINNULL>
11:17:41 DR: DRAUTO is 0 (Off)
11:17:41 DR: ENCRYPT_HDR is 0 (HDR encryption Disabled)
11:17:41 Event notification facility epoll enabled.
11:17:41 IBM Informix Dynamic Server Version 11.50.FC6 Software Serial
Number
AAA#B000000
11:17:42 IBM Informix Dynamic Server Initialized -- Shared Memory
Initialized.
11:17:42 Physical Recovery Started at Page (1:262570).
11:17:42 Physical Recovery Complete: 0 Pages Examined, 0 Pages Restored=
.
11:17:42 Logical Recovery Started.
11:17:42 10 recovery worker threads will be started.
11:17:43 Logical Recovery has reached the transaction cleanup phase.
11:17:43 Logical Recovery Complete.
0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
11:17:44 oninit: Fatal error in shared memory initialization
11:17:44 IBM Informix Dynamic Server Stopped.
11:17:44 mt_shm_remove: WARNING: may not have removed all/correct segme=
nts
Here is the shared memory configuration:
RESIDENT -1
SHMBASE 0x44000000
SHMVIRTSIZE 393216
SHMADD 65536
EXTSHMADD 32768
SHMTOTAL 0
SHMVIRT_ALLOCSEG 0.000000
SHMNOACCESS M|
Thoughts?
Jonathon Wyza
CX & CBORD System Administrator
CX Programmer/Analyst
Administrative Computing
Bethel College
(574)-257-3381
AIM: Iamwyza
jonathon.wyza@bethelcollege.edu<mailto:jonathon.wyza@bethelcollege.edu>=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D
SLES 11x64 & IDS 11.50.FC6
"Don't document the problem, fix it."
- Atli Bj=F6rgvin Oddsson
***********************************************************************=
********
Forum Note: Use "Reply" to post a response in the discussion forum.
=
Jonathon wrote:
<stuff cut>
11:17:43 Logical Recovery has reached the transaction cleanup phase.
11:17:43 Logical Recovery Complete.
0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
11:17:44 oninit: Fatal error in shared memory initialization
11:17:44 IBM Informix Dynamic Server Stopped.
11:17:44 mt_shm_remove: WARNING: may not have removed all/correct segments
Here is the shared memory configuration:
RESIDENT -1
SHMBASE 0x44000000
SHMVIRTSIZE 393216
SHMADD 65536
EXTSHMADD 32768
SHMTOTAL 0
SHMVIRT_ALLOCSEG 0.000000
SHMNOACCESS M|
Thoughts?
Jonathon Wyza
Response:
Well, you could try to bring it up with oninit -v to possibly get a better
idea where the server failed as it was trying to come online. From the online
log, it looks as thought it was about to, or did complete logical recovery,
and I believe at that point, it would have tried to do a checkpoint and flush
the reserve pages to disk. It's possible that's where it's failing. If you
want this server up, you are likely going to have to engage tech support. I
wouldn't think you are crashing into some other shared memory, as I believe by
this point, that should all be done, as it appears the server was trying to do
the recovery portion of coming online. You might try and run oncheck -pr/-cr
and when doing a -pr look for maybe disabled dbspaces or down chunks, however,
I would have thought if you hit a down chunk/disabled dbspace there would be
better messages in the online.log, unless maybe its the root chunk.
Jacques Renaut
IBM Informix Advanced Support
APD Team
Did your Systems Administrator allocate enough Shared Memory for this
server?
Thanks,
*******************************************************************
Ernie Knox
IT Database Administrator Specialist
Sears Holdings - BU: I & T Group
3333 Beverly Rd., B4-266A
Hoffman Estates, IL. 60179
Office: (847) 286-5735
Email: Ernest.Knox@searshc.com
Blackberry: 2244650553@messaging.sprintpcs.com
Page via Skytel: 2244650553@sprint.skytel.com
Informix or MySQL Primary: 9110210@skytel.com
Informix or MySQL Secondary: 7276872@skytel.com
" Yes we can make a Change! "
" It's always a great day to watch Sports - GO LIONS, TIGERS, and BEARS!
"
" Lets not forget - GO Pistons and Red Wings! "
GSU
*******************************************************************
-----Original Message-----
From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of
JACQUES RENAUT
Sent: Tuesday, September 07, 2010 11:39 AM
To: ids@iiug.org
Subject: Re: fatal error in shared memory initialization [21194]
Jonathon wrote:
<stuff cut>
11:17:43 Logical Recovery has reached the transaction cleanup phase.
11:17:43 Logical Recovery Complete.
0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
11:17:44 oninit: Fatal error in shared memory initialization
11:17:44 IBM Informix Dynamic Server Stopped.
11:17:44 mt_shm_remove: WARNING: may not have removed all/correct
segments
Here is the shared memory configuration:
RESIDENT -1
SHMBASE 0x44000000
SHMVIRTSIZE 393216
SHMADD 65536
EXTSHMADD 32768
SHMTOTAL 0
SHMVIRT_ALLOCSEG 0.000000
SHMNOACCESS M|
Thoughts?
Jonathon Wyza
Response:
Well, you could try to bring it up with oninit -v to possibly get a
better
idea where the server failed as it was trying to come online. From the
online
log, it looks as thought it was about to, or did complete logical
recovery,
and I believe at that point, it would have tried to do a checkpoint and
flush
the reserve pages to disk. It's possible that's where it's failing. If
you
want this server up, you are likely going to have to engage tech
support. I
wouldn't think you are crashing into some other shared memory, as I
believe by
this point, that should all be done, as it appears the server was trying
to do
the recovery portion of coming online. You might try and run oncheck
-pr/-cr
and when doing a -pr look for maybe disabled dbspaces or down chunks,
however,
I would have thought if you hit a down chunk/disabled dbspace there
would be
better messages in the online.log, unless maybe its the root chunk.
Jacques Renaut
IBM Informix Advanced Support
APD Team
************************************************************************
*******
Forum Note: Use "Reply" to post a response in the discussion forum.