Informix and linux :error 25588
Posted in 1999
Topics: Installation, Setup & Upgrades, Connectivity: ESQL/C, 4GL & Embedded SQL, Server Administration, Networking & sqlhosts Configuration, Platform-Specific Issues
Hi,
We have installed the package ids-7.30 and iconn-2.10 on a linux
RedHat6.0.Kernel 2.2.5-15
BUT we don't have install the cdsk package. Is it our problem?
We have created 2 users accounts : informix under an informix group
and an informixadmin user under an informixadmin group
We run the install scripts : installconn and installserver
We set the environnement variables.
PATH= ... :/opt/informix/bin
INFORMIXDIR = /opt/informix
INFORMIXSERVER=demo_on
LD_LIBRARY_PATH=/opt/informix/lib:/opt/informix/lib/esql
We configure the sqlhost file
demo_on onipcshm linux48 sqlexecdemo_se seipcpip linux48 sqlexec
we configure the services file in /etc
sqlexec 1526/tcp #informix
Here we are we lunch the dbaccessdemo7 with the root privilege or the
informix privilege and we have the following error :
25588 : The appl process cannot connect to Dynamic server demo-on
[We found this following explanation for this error :
25588 The appl process cannot connect to the database server .
An error in the application can produce this
message. Check your CONNECT
statement and the sqlhosts file. A system failure
can also produce this message. If you
can find no immediate cause for the failure, note
the circumstances and contact your
database server administrator for assistance.
The shared memory communication subsystem is down or
not functioning. Contact the
database server administrator to report the problem.
]
Where should we search for understanding our errors?
Please reply to ndl@infonie.fr
You did everything but start up the database engine. BTW it is better to
install the software in a subdir or /opt/informix named acording to the
version so that you can easily upgrade in a new directory and be able to
fall back to the original software if there are any problems, FWIW.
Now you have to set up the $ONCONFIG file (normally named:
$INFORMIXDIR/etc/onconfig.$INFORMIXSERVER)
either by hand or using the onmonitor utility. First copy
$INFORMIXDIR/etc/onconfig.std to $INFORMIXDIR/etc/onconfig.$INFORMIXSERVER
and set the environment variable ONCONFIG=onconfig.$INFORMIXSERVER. Then
in onmonitor go to Parameters>Shared-Memory and fill in the parameters
making any adjustments from the defaults. Next go to
Parameters>Initialize and fill in those parameters including a disk file
or device for Root Primary Path, and if needed the Mirror Path. Save and
use onmonitor or oninit to start the engine and bring it to OnLine status.
Now you are ready to connect. BUT, you really should create other
dbspaces for your database to live in (databases should NOT live in the
rootdb space which is unfortunately the default) and perhaps move the
logical and physical logs to other dbspaces as well (they initially must
be created in the rootdb space as the engine must be online to create the
other dbspaces to begin with).
Read the Administrator's Guide, available online on the Informix WEB Site
if you did not get the docs CD, for further details.
Art S. Kagel
"Nicolas DELATTRE (Gibbon Informatique)" wrote:
>
> Hi,
> We have installed the package ids-7.30 and iconn-2.10 on a linux
> RedHat6.0.Kernel 2.2.5-15
> BUT we don't have install the cdsk package. Is it our problem?
>
> We have created 2 users accounts : informix under an informix group
> and an informixadmin user under an informixadmin group
>
> We run the install scripts : installconn and installserver
>
> We set the environnement variables.
> PATH= ... :/opt/informix/bin
> INFORMIXDIR = /opt/informix
> INFORMIXSERVER=demo_on
> LD_LIBRARY_PATH=/opt/informix/lib:/opt/informix/lib/esql>
> We configure the sqlhost file
> demo_on onipcshm linux48 sqlexec> demo_se seipcpip linux48 sqlexec
>
> we configure the services file in /etc
> sqlexec 1526/tcp #informix
>
> Here we are we lunch the dbaccessdemo7 with the root privilege or the informix
> privilege and we have the following error :
> 25588 : The appl process cannot connect to Dynamic server demo-on
> [We found this following explanation for this error :
> 25588 The appl process cannot connect to the database server .
> An error in the application can produce this message.
> Check your CONNECT
> statement and the sqlhosts file. A system failure can also
> produce this message. If you
> can find no immediate cause for the failure, note the
> circumstances and contact your
> database server administrator for assistance.
>
> The shared memory communication subsystem is down or not
> functioning. Contact the
> database server administrator to report the problem.
> ]
>
> Where should we search for understanding our errors?
> Please reply to ndl@infonie.fr
Thanks to all your precisious advise :
after a :
cd /dev
cat /dev/null > rsd1f
chown informix rs1df
chgrp informix rs1df
chmod 660 rs1df
and a ROOTPATH=/dev/rsd1f
and TAPEDEV=/dev/rta1f
the oninit -ivy works fine,
the dbaccessdemo7 too
and the dbaccess too...
IT'S A WONDERFULL NIGHT AND I'm GOING TO BED IN
PARIS...
"Nicolas DELATTRE (Gibbon Informatique)" wrote:
> Hi,
> We have installed the package ids-7.30 and iconn-2.10 on a linux
> RedHat6.0.Kernel 2.2.5-15
> BUT we don't have install the cdsk package. Is it our problem?
>
> We have created 2 users accounts : informix under an informix group
> and an informixadmin user under an informixadmin group
>
> We run the install scripts : installconn and installserver
>
> We set the environnement variables.
> PATH= ... :/opt/informix/bin
> INFORMIXDIR = /opt/informix
> INFORMIXSERVER=demo_on
> LD_LIBRARY_PATH=/opt/informix/lib:/opt/informix/lib/esql>
> We configure the sqlhost file
> demo_on onipcshm linux48 sqlexec> demo_se seipcpip linux48 sqlexec
>
> we configure the services file in /etc
> sqlexec 1526/tcp #informix
>
> Here we are we lunch the dbaccessdemo7 with the root privilege or the
> informix privilege and we have the following error :
> 25588 : The appl process cannot connect to Dynamic server demo-on
> [We found this following explanation for this error :
> 25588 The appl process cannot connect to the database server .
> An error in the application can produce this
> message. Check your CONNECT
> statement and the sqlhosts file. A system failure
> can also produce this message. If you
> can find no immediate cause for the failure, note
> the circumstances and contact your
> database server administrator for assistance.
>
> The shared memory communication subsystem is down
> or not functioning. Contact the
> database server administrator to report the
> problem.
> ]
>
> Where should we search for understanding our errors?
> Please reply to ndl@infonie.fr
Just remember that if you bring the engine down again you do not want to run
'oninit' with the '-i' option. Otherwise you will lose all your new data!
-CZ
Nicolas DELATTRE (Gibbon Informatique) <ndl@gibbon.fr> wrote in message
news:381F58FC.77758320@gibbon.fr...
> Thanks to all your precisious advise :
> after a :
> cd /dev
> cat /dev/null > rsd1f
> chown informix rs1df
> chgrp informix rs1df
> chmod 660 rs1df
>
> and a ROOTPATH=/dev/rsd1f
> and TAPEDEV=/dev/rta1f
>
> the oninit -ivy works fine,
> the dbaccessdemo7 too
> and the dbaccess too...
>
> IT'S A WONDERFULL NIGHT AND I'm GOING TO BED IN
> PARIS...
>
>
> "Nicolas DELATTRE (Gibbon Informatique)" wrote:
>
> > Hi,
> > We have installed the package ids-7.30 and iconn-2.10 on a linux
> > RedHat6.0.Kernel 2.2.5-15
> > BUT we don't have install the cdsk package. Is it our problem?
> >
> > We have created 2 users accounts : informix under an informix group
> > and an informixadmin user under an informixadmin group
> >
> > We run the install scripts : installconn and installserver
> >
> > We set the environnement variables.
> > PATH= ... :/opt/informix/bin
> > INFORMIXDIR = /opt/informix
> > INFORMIXSERVER=demo_on
> > LD_LIBRARY_PATH=/opt/informix/lib:/opt/informix/lib/esql> >
> > We configure the sqlhost file
> > demo_on onipcshm linux48 sqlexec> > demo_se seipcpip linux48 sqlexec
> >
> > we configure the services file in /etc
> > sqlexec 1526/tcp #informix
> >
> > Here we are we lunch the dbaccessdemo7 with the root privilege or the
> > informix privilege and we have the following error :
> > 25588 : The appl process cannot connect to Dynamic server demo-on
> > [We found this following explanation for this error :
> > 25588 The appl process cannot connect to the database server .
> > An error in the application can produce this
> > message. Check your CONNECT
> > statement and the sqlhosts file. A system failure
> > can also produce this message. If you
> > can find no immediate cause for the failure, note
> > the circumstances and contact your
> > database server administrator for assistance.
> >
> > The shared memory communication subsystem is down
> > or not functioning. Contact the
> > database server administrator to report the
> > problem.
> > ]
> >
> > Where should we search for understanding our errors?
> > Please reply to ndl@infonie.fr
>
>