Re: Phantom error 956 ...
Posted in 2004
kaskarria@yahoo.es (Jordi Tous) wrote in message news:<643f9bf1.0409210836.3a96e37@posting.google.com>...
> Hi gurus!
>
> Is there anybody ???
>
>
>
> kaskarria@yahoo.es (Jordi Tous) wrote in message news:<643f9bf1.0409170554.686fa5b6@posting.google.com>...
> > Hi everybody,
> >
> > I have a problem when traing to access across two different IDS in
> > two different servers ...
> >
> > 1.- IDS server Linux-dokum
> > ==========================
> > IDS 9.30.UC3
> > Linux dokum 2.4.22-26mdkenterprise
> >
> > 2.- IDS server Solaris-sf4800
> > =============================
> > IDS 7.31.FD5
> > SunOS sf4800 5.8 Generic_108528-16 sun4u sparc SUNW,Sun-Fire
> >
> >
> > In the IDS930 I have a database albarantest with a table
> > with the schema as below :
> >
> > create table albaran
> > (
> > albid serial not null ,
> > albaran char(30),
> > partida integer,
> > imagen blob,
> > usrins varchar(18) default user not null ,
> > fecins date default today not null ,
> > usrupd varchar(18) default user not null ,
> > fecupd date default today not null
> > );
> > create index i_albaran1 on albaran (albaran);
> > create index i_albaran2 on albaran (usrins,fecins);
> > create index i_albaran3 on albaran (partida);
> > create unique index p_albaran on albaran (albid);> >
> > In the IDS731 there are a view against the table of the IDS930 as below :
> >
> > create view v_albaran as
> > select albaran, partida from albaranhamann@ol_dokum:albaran;> >
> > As you see, the blob column of the table is ommited in the view, cause
> > IDS731 don't support this kind of data type !
> >
> > The view on IDS731 has been created to do selects as :
> >
> > SELECT COUNT(*) FROM v_albaran WHERE partida = ???> >
> > The problem, reproduced in dbaccess, is that many times, but not allways,
> > i try to execute the SELECT COUNT(*) ... statment from dbaccess in IDS731,
> > and error like :
> >
> > >>956: Client host or user (wwwzar@a11b5505) is not trusted by the server
i'm not a guru, but a11b5505 seems to say that the ip address of the hosts
is not resolved. could you check your hosts files on both server ou name
server.
regards,
> >
> > is showed!!!
> >
> > If you try to run the statment again the sistem goes and the statment is
> > succesfully executed, so the problem related for 956 error is solvented ???
> >
> > Sometimes it goes and sometimes it doesn`t ... Anyone has any idea ??
> >
> > Thanks in advance!