Chunk does not appear to be from an external backup
Posted in 2009
Topics: High Availability & Replication, Storage & Space Management, Error Codes & Troubleshooting, Platform-Specific Issues
Hi,
Has anyone ever seen a message in the online.log concerning external backup such as:
“The first chunk of dbspace’report08:grand.cust_pri’ does not appear to come from an external backup”?
At the same time the application log started getting SQL -271 Could not insert new row into the table and ISAM -136 ISAM error: no more extents mesaages in the application log.
The server is an HDR primary on IDS 11.50.FC2X2 on an HP-UX ia64 platform.
The particular table being mentioned in the online.log message resides in one dbspace and has a first and next extent size of approximately 2 GB. There are three separate indexes with each index being in a separate dbspace. The table in question only has 17 extents. The application placed over 90 million records in the table and then the message in the online.log started happening, along with the SQL and ISAM error messages in the application log.
There is only one chunk in the dbspace that holds the cust_pri table and onstat –d shows that the dbspace has approximately 232 GB of which approximately 229 GB is free.
We use BCV’s for backups and restores. Since there is plenty of free disk space I am wondering when the message in the online log really means. Has anyone seen the error regading chunk and external backup before and do you have any suggestions?
Regards,
Bruce
brucemarchu@aol.com wrote:
> Hi,
>
> Has anyone ever seen a message in the online.log concerning external
> backup such as:
> “The first chunk of dbspace’report08:grand.cust_pri’ does not appear to
> come from an external backup”?
>
> At the same time the application log started getting SQL -271 Could
> not insert new row into the table and ISAM -136 ISAM error: no more
> extents mesaages in the application log.
>
> The server is an HDR primary on IDS 11.50.FC2X2 on an HP-UX ia64 platform.
>
> The particular table being menti oned in the online.log message resides
> in one dbspace and has a first and next extent size of approximately 2
> GB. There are three separate indexes with each index being in a
> separate dbspace. The table in question only has 17 extents. The
> application placed over 90 million records in the table and then the
> message in the online.log started happening, along with the SQL and
> ISAM error messages in the application log.>
> There is only one chunk in the dbspace that holds the cust_pri table and
> onstat –d shows that the dbspace has approximately 232 GB of which
> approximately 229 GB is free.
>
> We use BCV’s for backups and restores. Since there is plenty of free
> disk space I am wondering when the message in the online log really
> means. Has anyone seen the error regading chunk and external backup
> before and do you have any suggestions?
>
> Regards,
> Bruce
>
> ------------------------------------------------------------------------
> *A Good Credit Score is 700 or Above. See yours in just 2 easy steps!
> <http://pr.atwola.com/promoclk/100126575x1220439616x1201372437/aol?redir=http:%2F%2Fwww.freecreditreport.com%2Fpm%2Fdefault.aspx%3Fsc%3D668072%26hmpgID%3D62%26bcd%3DfebemailfooterNO62>*
>
Please contact technical support.
You're probably suffering from two issues:
1- You have reached the limit on the number of pages of a single fragment
2- IDS is giving you the wrong message
1) can be solved by implementing some kind of fragmentation scheme on the table
2) can be solved by upgrading (since you're using a custom fix - X2 - you may
have other reasons that prevent you from upgrading
Nevertheless your situation must be analyzed by tech support. They can confirm
if the above is correct.
Regards.
--
Fernando Nunes
Portugal
http://informix-technology.blogspot.com
My email works... but I don't check it frequently...
I have had a problem when the external backup has not been performed in the
"approved" manner; ie there was no onmode -c block performed.
If this seems that it might match your situation have a look at
http://groups.google.co.uk/group/comp.databases.informix/browse_thread/thread/8fcbc64b81f42abd?hl=en#
to see if the details are similar ...
<brucemarchu@aol.com> wrote in message
news:mailman.450.1238439846.1831.informix-list@iiug.org...
>> Has anyone ever seen a message in the online.log concerning external
>> backup such as:
>> “The first chunk of dbspace’report08:grand.cust_pri’ does not appear to
>> come from an external backup”?
Hi Neil,
Thanks for the additional information. We normally use the onmode -c block and onmode -c unblock for our BCV backups and restores. The additional information that you sent was interesting and informative. I think that the databaase is starting to hit the approximate 16 million page limitation for a table and that the table will need to be fragmented. I will be taking to IBM support to confirm the situation.
Thanks again,
Bruce
-----Original Message-----
From: Neil Truby <neil.truby@ardenta.com>
To: informix-list@iiug.org
Sent: Mon, 30 Mar 2009 6:08 pm
Subject: Re: Chunk does not appear to be from an external backup
I have had a problem when the external backup has not been performed in the
approved" manner; ie there was no onmode -c block performed.
If this seems that it might match your situation have a look at
ttp://groups.google.co.uk/group/comp.databases.informix/browse_thread/thread/8fcbc64b81f42abd?hl=en#
to see if the details are similar ...
brucemarchu@aol.com> wrote in message
ews:mailman.450.1238439846.1831.informix-list@iiug.org...
> Has anyone ever seen a message in the online.log concerning external
> backup such as:
> “The first chunk of dbspace’report08:grand.cust_pri’ does not appear to
> come from an external backup”?
_______________________________________________
nformix-list mailing list
nformix-list@iiug.org
ttp://www.iiug.org/mailman/listinfo/informix-list
Related threads
- RE: transfer via comp.databases.informix
- dbimport hangs
- Assert Failed errno 271 ISAM ERR -12803
- Syslocks table