Re: Server Crash
Posted in 1998
Schultheis, Carol L wrote:
>
> We're running Online 7.11 on HP UX 9.01 and my server just crashed with the
> following errors listed in the log:
>
> 10:37:06 dynamically allocated new shared memory segment (size 2097152)
>
> 10:37:16 Pool = 0xc084c010, Pool name = mt, Blkhdr = 0xc0fb5040
> 10:37:16 Block magic is -15641, expecting 4
> 10:37:16 Possible memory block header corruption
> 10:37:16 mtshpool.c, line 2535, thread 8, proc id 220, Condition Failed
> (CHECK_ALLOC_BLOCK), In (mt_shm_free) Thread(8, sm_poll, 0, 1).
> 10:37:16 PANIC: Attempting to bring system down>
> I was able to restart the server with no problem, but I'm wondering if
> anyone can enlighten me as to what this means, and if there's an underlying
> problem that I should be addressing.
This usually means that some process connected through shared memory
has corrupted some part of shared memory by overwriting it and caused
the engine to panic and shut down. Look for free()s of non-malloc
addresses, freeing a statement that is being accessed by an active
cursor declared on it (the cursor should be closed and freed first),
Redeclaring cursors or statements that have been closed but not freed,
overrunning array boundaries, etc. One way to track this down is to
change the connection to stream pipes or tcp/ip and then the offending
app will crash instead.
Art S. Kagel