Re: ESQL: Unknown error message -33071.
Posted in 1997
In <4E117EB31591D011B3FB0000F81E522213C797@atlantic.tesent.com>,
>Farrell, Mike wrote:
>We are trying to compile the ESQL demos and the compile fails with the
>error message: Unknown error message -33071. We believe it is the
>result of some unset environment variable. Has anyone seen this error
>message? What are the required environment variables that must be set
>to compile ESQL/C?
Mike,
This is the same kind of problem as the following one, so read the
following, it will provide you the answer. In that case they were having
problem with dbaccess, you are having problem in accessing the compile
scripts.
--
Have a nice day
Felix K. Mathews
mailto:fmathews@systems.dhl.com
________________________________________________________________________
In <01BC3867.BE5BB780@swong.den.csci.csc.com>, Sean Wong wrote:
>I have just posted a question yesterday, and I need you IFMX doers and
>thinkers to give me help again on 'dbaccess'.
>
>This time, o/s is : "hp-ux 10.01 C"; OnLine 5.08.UC1; isql: 4.14.UC1;
>dbaccess:5.08.UC1
>
>When I attached to an OnLine instance under my own login, I haveno
>problem of running 'isql' and 'dbaccess'. However, if I login as user
>'informix', when I try to run 'dbaccess', the engine returned me
>following error:
> 23101: Unknown error message -23101>
>But there is no problem with 'isql'. Has someone come across this
>before? The order in the '.snfile' is : SQL, 4GL, ESQL/C, OnLine.
Sean,
Do you have more than one version of Informix installed in your machine.
In which case when you run "dbaccess" it could probably be executiong
dbaccess from the other directory ( because of your $PATH ). When you
execute dbaccess or similar tools if the related files like messages etc
are not under that INFORMIXDIR, it will give you
?????: Unknown error message -?????
Basically you need to have the engine,tools,messages,etc. under the same
directory(INFORMIXDIR), if it is not, then you need to reinstall.
In case of 2-versions of Informix say V7.0 & V7.2 if your INFORMIXDIR is
pointing to V7.0, but your $PATH points V7.2 before V7.0 (
PATH=...:V7.2:...:V7.0... ) then by typing "dbaccess" you are executingV7.2's "dbaccess". Now messages and related files under $INFORMIXDIR is
of V7.0. This will give you an "?????: Unknown error message -?????"
Check which dbaccess will be executed, by "type dbaccess".
Good Luck
Felix K. Mathews