RE: Fatal error in shared memory during system reboot
Posted in 2005
Did you shut down properly ? If you did not, you will first have to
delete the files in /INFORMIXTMP before starting up.
-----Original Message-----
From: owner-informix-list@iiug.org [mailto:owner-informix-list@iiug.org]
On Behalf Of steven_nospam at Yahoo! Canada
Sent: 24 August 2005 08:15 PM
To: informix-list@iiug.org
Subject: Fatal error in shared memory during system reboot
Scenario:
=========
During a system reboot, our startup routines are automated and try to
bring up the Informix instances. These are standard commands that
usually work without incident.
The startup process (PID 1) runs a script in the inittab that sets the
Informix environment and issues "oninit" followed by "onstat -" a few
seconds later. These activities are logged so we can see what happens.
Problem:
========
Some of our systems are giving the following messages:
>Starting up instance...Executing "oninit" for instance "data1"
>oninit: Fatal error in shared memory creation
>
>Verifying instance "data1" status using "onstat -"...
>IBM Informix Dynamic Server Version 9.40.FC3 -- On-Line -- Up
When we check the instance afterward, it has shut itself down. However,
if we run the same script from a terminal after the system has been
started, the instance starts up fine. To top it all off, we have
another site using the same version and O/S level, same startup
routine, and it starts fine on that one.
>Starting up instance...Executing "oninit" for instance "data2"
>
>Verifying instance "data2" status using "onstat -"...
>IBM Informix Dynamic Server Version 9.40.FC3 -- On-Line -- Up
Any ideas why during a system reboot the instance may not want to
start, but will start okay afterward? Nothing should be in ipcs at that
point to interfere, but the only error I get from "onstat -m" complains
about a shared memory conflict:
09:55:43 IBM Informix Dynamic Server Started.
09:55:43 shmget: [EEXIST][17]: key 52584801: shared memory alreadyexists
09:55:43 mt_shm_init: can't create resident segment
Environment:
============
IBM RS/6000 Running AIX 5.2 (64-bit)
Informix IDS 9.40 FC3
sending to informix-list