=?iso-8859-1?Q?RE=3A_Can=B4t_recreate_index_on_temp_tab?=
Posted in 2005
The following script works fine with 9.40uc6 (ANSI database):
--#####
create temp table aaa(col1 int) with no log;
create index aaa_idx on aaa(col1);rollback work;
create temp table aaa(col1 int) with no log;
create index aaa_idx on aaa(col1);--#####
(Please, note, that transactions are started implicitly
in ANSI database with the first SQL statement - like in Oracle and DB2)
Also works wine with 9.21
There is either a bug in 9.40xC3, or you are missing smth...
Can You publish a small script that reproduces the problem?
-Alexey
> -----Original Message-----
> From: owner-informix-list@iiug.org [mailto:owner-informix-list@iiug.org] On
> Behalf Of J?rg Spilker
> Sent: Tuesday, January 25, 2005 7:33 AM
> To: informix-list@iiug.org
> Subject: Can't recreate index on temp tab
>
> We're running Informix Dynamic Server 9.40.FC3 on a HP alpha cluster
> node. One of our applications is creating temp table's with indexes
> within a transaction. When the transaction is rolled back, the temp
> tables are gone. However if the application tries to recreate the temp
> tables and indexes in the same session, creating the indexes always
> fails with:
>
> SQL statement error number -242.
> Could not open database table (12spilk.t_tmp_fasumme)
> SYSTEM error number -106.
> ISAM error: non-exclusive access.>
> How can i avoid this problem?
sending to informix-list