RE: ODBC error -23101 Unable to load locale categories
Posted in 2004
Topics: Installation, Setup & Upgrades, Connectivity: ODBC / JDBC / .NET, Internationalization & Character Sets
Hi. Try as below. Open ODBC setup window. Click Enviroment tab. Put %INFORMIXDIR%(Change your installed directory)\\bin\\ig04n304.dll on Translation library. Just my $0.02. -- Tsutomu Ogiwara from Tokyo Japan. ICQ#:168106592 >From: "jded" <jdendrinos@hotmail.com> >Reply-To: "jded" <jdendrinos@hotmail.com> >To: informix-list@iiug.org >Subject: ODBC error -23101 Unable to load locale categories >Date: 2 Dec 2004 12:01:22 -0800 > >I'm trying to connect to an Informix database server on a Unix machine >from Windows XP. I'm using Informix ODBC Driver ver. 3.2.81 TC2. >I can connect to other databases but if I try this I get this error >about the locales. The difference of this database is that it has >greek.iso88597 DB_Locale. > > >From ODBC "Apply and Test" I'm getting these errors: >1)If I try the option Use Server Database Locale I'm getting >"Unable to load locale categories" >Database Locale : greek.iso88597 >Client Locale : en_US.CP1252 > >2)If I don't use Server Database Locale I'm getting "Code sets of >the locales categories are not the same" >Database Locale : en_US.CP1252 >Client Locale : en_US.CP1252 > sending to informix-list
afaikr the greek locale is part of an extra package. could be called informix language supplement?? you may want to contact support on this. Superboer. "Tsutomu Ogiwara" <tsutomu_ogiwara@hotmail.com> wrote in message news:<1102041510.fR8DIW5OJleMigsyIKjegw@teranews>... > Hi. > > Try as below. > > Open ODBC setup window. > Click Enviroment tab. > Put %INFORMIXDIR%(Change your installed directory)\\bin\\ig04n304.dll on > Translation library. > > Just my $0.02. > > -- > Tsutomu Ogiwara from Tokyo Japan. > ICQ#:168106592 > > > > > >From: "jded" <jdendrinos@hotmail.com> > >Reply-To: "jded" <jdendrinos@hotmail.com> > >To: informix-list@iiug.org > >Subject: ODBC error -23101 Unable to load locale categories > >Date: 2 Dec 2004 12:01:22 -0800 > > > >I'm trying to connect to an Informix database server on a Unix machine > >from Windows XP. I'm using Informix ODBC Driver ver. 3.2.81 TC2. > >I can connect to other databases but if I try this I get this error > >about the locales. The difference of this database is that it has > >greek.iso88597 DB_Locale. > > > > >From ODBC "Apply and Test" I'm getting these errors: > >1)If I try the option Use Server Database Locale I'm getting > >"Unable to load locale categories" > >Database Locale : greek.iso88597 > >Client Locale : en_US.CP1252 > > > >2)If I don't use Server Database Locale I'm getting "Code sets of > >the locales categories are not the same" > >Database Locale : en_US.CP1252 > >Client Locale : en_US.CP1252 > > > > > sending to informix-list