Re: grant, revoke and ownership
Posted in 1997
In article <33B17D42.6DF@no.spam>, Peter Jennings <no.spam@no.spam>
writes
>We are running Online 5 under AIX 3.2.5 (soon to be upgraded to 7.2
>under AIX 4.1.5)
>
>Our customer requires that all tables in his system be owned by
>informix, even those created by other users (in ESQL-C or shell
>scripts). In addition many of the tables require revoking of all
>privilages from "public" and then granting just, say, select.
>
>Users with dba privilage have no problem creating a table owned by
>informix eg:-
>exec sql create table informix.my_name (...etc...);
>which creates a table with all privilages granted to public.
>
>However if the user now attempts to "revoke all on my_name from public"
>there are no error messages, the sqlca structure shows all zeros in the
>significant places and the command appears to have been executed. The
>same thing happens if the user does this from inside isql. BUT the
>information on the table shows that public still has all privilages
>granted. Adding "as informix" to the command has no effect.
>
Have you tried running the revoke command in dbaccess?
Possibly you are missing an error somewhere?
have you then tried logging in as an unpriviledged user and
trging to select from the table?
Revoke you revoked database level privileges from public?
Revoke connet and resource privileges at the database level?
>Is this a "feechur" of Online 5 or should we be doing something else /
>different?
>
Sounds like either you are doing something wrong or Informix is
(i.e. a bug). I would try all the above first...
>Peter.
--
David Williams