Re: restarting sqlexecd
Posted in 1995
> Reply-To: Mark Wingate <mark@elsouth.com> > Subject: [NEWS] restarting sqlexecd > > I had a situation where I had to kill the sqlexecd process. > When I tried to re-start it, I got the following: > 25523 The sqlexecd daemon cannot bind the network structures.: \\ > System error: Address already in use > > Could I have cleared this condition without rebooting? > > Where would I find basic information on sqlexecd? specifically, > command line options > error messages > > Thanks in advance for any light you can shed, or places to look. > -- > Mark Wingate Electrical South LP mark@elsouth.com > Box 49239 > Greensboro, NC 27419-1239 > Mark, The first and MANDATORY step is to make level 0 Archive. I would download data from databases onto another tape in an ASCII format as well. Then make sure there is no sqlturbo (sqlexec) process hanging (PPID=1) If such process exists then 1. Disconnect all users and close all sessions 2. Try to kill stand-alone sqlturbo (sqlexec) process by 1, 2, 15 SIGNALS 2. Stop and restart Informix. Else ( no orphan sqlturbo ) Check for network state using UNIX Network Administration Tools. If a socket you reserved for sqlexecd is in use then 1. Destroy either connection or listener. Else 1. Reboot computer End if End if Informix applies a thin brochure named INFORMIX-NET and INFORMIX-STAR Installation/Configuration Guide. Refer it before. You can also find some information on sqlexecd behavior in $INFORMIXDIR/msg/errmsg.txt file ( error numbers begining from 255 ) Take care, Pavel <pavel@cso.spb.su>