Re: Informix / Linux Assert nsfpipe.c errno = 22
Posted in 1999
Art S. Kagel <kagel@bloomberg.net> wrote:
: art wrote:
:>
:> Robert McQuire <rmcquire@tampabay.rr.com> wrote:
:> : Anyone gotten the following error message starting Informix on Linux?
:>
:> : Assert Failed: nsfpipe.c line 2096, thread 9, errno = 22, spipe error
:>
:> : Any help would be appreciated.
:>
:> hmm I am getting it also
:>
:> this is all I found
:>
:> #define EINVAL 22 /* Invalid argument */
: Right errno 22 is "Invalid argument to a system call". Looks like the
: FIFO that Informix creates to implement the ipcstrpip protocol already
: exists so the create FIFO system call fails with errno 22. Perhaps the
: system was shutdown without shutting the engine down first. Make sure
: you have a shutdown script for the Informix engine in you rc.d shutdown
: subdirectory.
: Art S. Kagel
more info that I just found out
if I set
NUMCPUVPS 1 # Number of user (cpu) vps
to greater than 1 (tested with 2 and 3) and I then try to access
it remotly it throws this error