RE: Upgrade to IDS 10.00.UC* [5790]
Posted in 2005
Bob,
First of all, the 'previous IDS' shutdown process should be:
onmode -kuy
oninit -s
onmode -c
onmode -kuy;
...Then, start the new IDS version.
Also, 'update statistics for procedure' is required after the upgrade.
-Alexey
> -----Original Message-----
> From: forum.subscriber@iiug.org [mailto:forum.subscriber@iiug.org] On
Behalf
> Of Bob Roussey
>
> RedHat AS 3, running IDS 9.40.UC2, 9GB RAM, 4cpus
>
> Installed IDS 10.00.UC3 (most current) and tried to upgrade a copy
of a
> production db. Followed the suggestions in the Migration manual
(after the
> upgrade failed once) and brought the system up with 10. Stopped the
instance
> under 9.4, did the "onmode -c", "ontape -a" and "onmode -yuk".
Switched
> $INFORMIXDIR and used "oninit".
>
> Online.log seems to show everything upgraded ok; no errors or
failures.
> When I started a copy of our production apps, db AF'd and shut down,
> complaining that:
>
> 12:44:29 Conv/rev: Failed to convert component SQL to componentversion 26
> 12:44:29 Conversion failed for component SQL : entity_ver 26 !=target
> version
> 29
> 12:44:29 Assert Failed: Conv/rev: Failed to convert for component SQL
> 12:44:29 IBM Informix Dynamic Server Version 10.00.UC3
> 12:44:29 Who: Session(30, root@resbetrn, 0, 0x8ff18c18)
> Thread(39, convert, 8feeff20, 1)
> File: framework.c Line: 668
> 12:44:29 Results: Dynamic Server must abort
> 12:44:29 Action: Restart conversion after fixing the problem.>
>
> I then tried to do "update statistics" for the entire database
(which
> failed) and now I cannot even connect to our db, receiving the
following
> errors:
>
> 311: Cannot open system catalog (sysdirectives).
> 102: ISAM error: illegal argument to ISAM function.>
> It appears that no 'sysdirectives' table was ever built. Has anyone
else
> run into this? Are there *mandatory* steps required in order to
upgrade to 10
> from 9.40?
>
> Bob
sending to informix-list