Re: crashed online
Posted in 1995
Carol Stimmel (stimmel@fsl.noaa.gov) wrote: : Hi, : we are DOA. Usually running online RSAM Version 5.03.UC1, : we crashed a few days ago and have never been able to : re-initialize the shared memory. This is the last error : message in the log: : Fri Aug 25 11:50:21 1995 : 11:50:21 Cannot Open Primary Chunk '/dev/informix-1', errno = 6 : 11:50:21 I/O open() chunk 1, pagenum 0, pagecnt 1 --> errno = 6 Carol, In addition to checking your link and/or actual device /dev/informix-1, you can try to read from the device using dd: dd if=/dev/informix of=/dev/null bs=64k If it reads without error (may take a while), you've been hit by some sort of a transient glitch, maybe a disk problem, maybe not. Informix support can call into your system and massage some of the bits to bring it back up, but it does require a call-in (n/c if you have a support agreement). Any time Informix tries to read data and cannot, it retries several times and then marks the chunk as "down", necessitating either a support call or a restore from tape. I've had this happen when someone had a disk drive turned off at startup. Informix tried to hit the drive, failed, and marked the chunk as down. You can minimize the porblem by setting MIRROR to "1". This causes OnLine to initialize shared memory even though a chunk is down (unless it's the rootdbs). Call Informix! Joe -- --------------------------------------------------------------------------- Joe Lumbley(jlumbley@netcom.com) Dallas, Texas ----------------------------------------------------------------------------