ODBC Connection Problems
Posted in 1999
Topics: Connectivity: ODBC / JDBC / .NET
I have receive the following message from a 3rd party that is attempting to access one of our databases. He isn't haveing a whole lot of luck with Informix and/or Intersove in resolving it and aske me to look into it. I myself have not used the ODBC to connect and I'm hoping that somebody could shead some light onto this. Thanks. Please reply directly to matt.blackburn@haushahn.com --------------------------------------------------------------------------------------------------------------------------------------------------------- Here's the error message we get every 2 to 4 days. 2/27/99 3:59:26 PM Cannot connect to Informix DB. #2 IM006: [INTERSOLV] [ODBC Informix driver]Driver's SQLSetConnectAttr failed. Our connection strategy is to connect - pull reciepts - disconnect, connect - pull reciepts - disconnect etc. etc. About every 45 seconds. The problem is that once we get the error message we can't reconnect.
Why so much connecting and disconnecting? He would be better off if he stayed connected all of the time and just reran his query every 45 seconds. That would get rid of a lot of overhead plus fix his problem. -- Regards, Robert Matthew S. Blackburn <matt.blackburn@haushahn.com> wrote in article <36e3ed00.493946848@news.iserv.net>... > I have receive the following message from a 3rd party that is > attempting to access one of our databases.......... > > Here's the error message we get every 2 to 4 days. > > 2/27/99 3:59:26 PM Cannot connect to Informix DB. > #2 IM006: > [INTERSOLV] [ODBC Informix driver]Driver's SQLSetConnectAttr failed. > Our connection strategy is to connect - pull reciepts - > disconnect, > connect - pull reciepts - disconnect etc. etc. About every > 45 > seconds. > The problem is that once we get the error message we can't reconnect. > >
Previously when they lost the connection to our instance of INFORMIX their connection would get corrupted and they would have to restart their application. This would happen whenever the ISTAR connection came down for what ever reason, or INFORMIX went off line. We has 1 instance when our box crashed for a physical memory error and when they lost the connection it corrupted their database they were keeping. So that is why they decided to go with the get / release method for access. Now, I haven't had any experience with the ODBC in such that an application I wrote access the database via it. I'm just providing an ISTAR conection for them to access data through. Also, this is a version 5.08 database running on a DEC Alpha 2100 ALP, running DEC Unix 3.2G We will be going to at least the following: (There is a possibility of upgrading the CPUS also, but that has yet to be determined) DEC Unix 4.0D Online 5.10.UC3 4GL 4.20.UC1 SQL 4.20.UC1 I'm currently not sure of the version of ISTAR or what the new version will be. On 10 Mar 1999 00:10:13 GMT, "RG" <rgriffin@farmerstel.com> wrote: >Why so much connecting and disconnecting? He would be better off if he >stayed connected all of the time and just reran his query every 45 seconds. > That would get rid of a lot of overhead plus fix his problem. >-- >Regards, >Robert > >Matthew S. Blackburn <matt.blackburn@haushahn.com> wrote in article ><36e3ed00.493946848@news.iserv.net>... >> I have receive the following message from a 3rd party that is >> attempting to access one of our databases.......... >> >> Here's the error message we get every 2 to 4 days. >> >> 2/27/99 3:59:26 PM Cannot connect to Informix DB. >> #2 IM006: >> [INTERSOLV] [ODBC Informix driver]Driver's SQLSetConnectAttr failed. >> Our connection strategy is to connect - pull reciepts - >> disconnect, >> connect - pull reciepts - disconnect etc. etc. About every >> 45 >> seconds. >> The problem is that once we get the error message we can't reconnect. >> >>