Authentication Error
Posted in 2005
Topics: Server Administration, Security, Permissions & Auditing
HI,
My original plan is to drop a database (ex. stores database).
- This informix engine was restored and started by root account.
- After bringing up the server still as root account, I tried to drop stores
database and I got this error " 359: Cannot drop or rename current database.".
- So I checked who has DBA permission on stores database and this is the
results:
username usertype priority password
admin D 9
admindba D 5
- Next thing I did, is login as 'admin' and run 'dbaccess'. But when I tried
to select a database this what I'm getting "25590: Authentication error. ". I
was thingking I could grant DBA to root using admin account but I can't gain
access to any of database.
- Tried re-starting the engine as admin account, still I do get the same
messages listed above using these two accounts.
Any suggestions would be greatly appreciated.
Thanks
Jose
I add
the same problem a while ago.
The cause was that the user o/s password was not matching the database
user password.
The solution was to change the user o/s pwd same as the database.
Diane
-----Original Message-----
From: forum.subscriber@iiug.org [mailto:forum.subscriber@iiug.org] On
Behalf Of JOSE STA. CRUZ
Sent: Monday, May 02, 2005 2:07 PM
To: ids@iiug.org
Subject: Authentication Error [4862]
HI,
My original plan is to drop a database (ex. stores database).
- This informix engine was restored and started by root account.
- After bringing up the server still as root account, I tried to drop
stores database and I got this error " 359: Cannot drop or rename
current database.".
- So I checked who has DBA permission on stores database and this is the
results:
username usertype priority password
admin D 9
admindba D 5
- Next thing I did, is login as 'admin' and run 'dbaccess'. But when I
tried to select a database this what I'm getting "25590: Authentication
error. ". I was thingking I could grant DBA to root using admin account
but I can't gain access to any of database.
- Tried re-starting the engine as admin account, still I do get the same
messages listed above using these two accounts.
Any suggestions would be greatly appreciated.
Thanks
Jose