We have a mysterious problem with IDS 7.21, the database freezes from
time to time, now I think I've found the reason: there may be more
connections open to the database than allowed in the licence. The
problem is, I don't know what the limit is, does anyone know how to find
out the maximum number of connections allowed? And, am I right with my
diagnosis? I thought that when I try to open too many connections, they
are refused but here it seems the machine accepts them and then hangs
for some time.
--Micha
↪ replying to Micha
I've made a test now - I've started 10 new processes and each has opened a
connection to the database. The effect was immediate - all CONNECT's have
succeeded without any error and the database froze until I've killed them.
Is this supposed to be the documented behaviour? Why are those CONNECTs not
refused with an SQL error message? This is IDS 7.31 on sunos_i386.
--Micha