RE: Infomrix -710 errors
Posted in 2005
-----Original Message----- From: owner-informix-list@iiug.org [mailto:owner-informix-list@iiug.org] On Behalf Of Konigsberg, Jay Sent: 02 August 2005 08:42 PM To: informix-list@iiug.org Subject: Infomrix -710 errors >I'm wondering who else out there has had a problem with -710 errors using >Informix 7 and/or 9? > >We had a lot of them with Informix 7.31 on AIX 4.3.3 and never solved the >problem. When we upgraded to Informix 9.4 (AIX 5.2) we moved the data via >"dump and reload" and the problem went away for a while. > >The problem seems greatest on a table called "update_source" which, while >static, has foreign keys to 25 other tables, most of which are updated >frequently and two of which are completely rebuilt (via drop/create table) >about once a week. Even so, we get the -710 on other tables as well with >the only common thread being that there is a large amount of insert/update >activity on the table(s). > >Full statistics are run every Sunday, partial stats are run daily and a >(very) few tables get stats multiple times a day. Procedure statistics are >run twice a day, every day. > >Anyone got a clue? > >Thanks, >Jay sending to informix-list [REPLY from Dirk] I think your error is caused by running update statistics. This happens when a program has a cursor open, and after opening you run update statistics on the table ....... sending to informix-list