Error: Onpload must run on the host (qroriondb) that contains the target database.
Posted in 2007
When trying to run an HPL load job with a command such as:
onpladm run job $JOB -p $PROJECT -fl -l {JOB}.log
I get the following in the corresponding onploaderr file:
"Error: Onpload must run on the host (qroriondb) that contains the
target database."
I am, however, on the host which contains the target database.
The problem would appear to be caused by the way we have the instance
configured on a Sun Cluster. There are two nodes in the cluster -
qroriondb1 and qroriondb2. The virtual node name being qroriondb. The
raw chunk devives reside on a SAN. So that I don't need to change the
SQLHOSTS file in the event of a cluster failover, I have configured it
with the cluster name (not the node names) as follows:
orion_prod_shm onipcshm qroriondb dummy
orion_prod_tcp ontlitcp qroriondb 17000
Is HPL really comparing the value returned by the UNIX hostname command
with the value for host name in the SQLHOSTS file?
Currently the active node is qroriondb1. If I change the SQLHOSTS file
as below and bounce the instance then HPL works fine.
orion_prod_shm onipcshm qroriondb1 dummy
orion_prod_tcp ontlitcp qroriondb1 17000
Naturally, I don't want to have to do this every time I want to use
HPL. Is there a better way I can get round this problem?
Thanks.