RE: Locking in Exclusive mode is not working as I thought!!!
Posted in 1999
The default isolation level on a non-logging database is dirty read I
beleive. That is why you could select the row. You would not however be able
to select for update if someone has a lock.
mac-
> -----Original Message-----
> From: owner-informix-list@iiug.org
> [mailto:owner-informix-list@iiug.org]On Behalf Of Carlson@WHSmith
> Sent: Friday, September 10, 1999 4:28 PM
> To: informix-list@iiug.org
> Subject: Re: Locking in Exclusive mode is not working as I thought!!!
>
>
> Here's the error message description:
>
> -256 Transaction not available.
>
> You cannot begin a transaction in this database because it
> does not have a transaction log. In order to support
> transactions you must start a transaction log. With the
> INFORMIX-OnLine Dynamic Server this is done by the
> OnLine administrator (using the Databases screen of the
> Logical Logs menu of DB-Monitor or ON-Monitor). With
> other database servers it is done using the START
> DATABASE statement.
>
>
> The given database isn't using transaction logging.
>
>
> Which drove me to some additional research . . . what happens when
> there's no transaction logging for the database?
>
> I was able to select on a table that was locked . . . truly peculiar.
>
> John Carlson
> Informix DBA
> WHSmith USA
>
> Mild wrote:
> >
> > I cannot get the following command to work on our database:
> >
> > set isolation to repeatable read> >
> > or
> >
> > set isolation to committed read> >
> > What happens is that I get an error message:
> > 256 Transaction not available
> >
> > Please help!!! What am I doing wrong?
> >
> > And if I try doing:
> >
> > begin work;
> > set isolation to ...> >
> > It still gives me the error message? :-(
> >
> > thanks,
> > Theron
>