Informix 10 & NetBackup 6
Posted in 2006
Topics: Backup & Restore
Hello
We are having problems with onabr and Veritas NetBackup. Our logical
logs are bing backed up to tape just fine but when we try to kick off a
level 0 on the Database, nothing gets written to the log.xxx file and
the onbar command immediately comes back to screen and no messages.
This is the only message we receive in bar_act.log :
2006-10-18 11:47:59 774338 241908
/home/informix/iif2000/ids_10_FC5/bin/onbar_d -b -L 0
2006-10-18 11:47:59 774338 241908 Working with veritas-netbackup as
generic storage manager.
2006-10-18 11:48:00 774338 241908
/home/informix/iif2000/ids_10_FC5/bin/onbar_d complete, returning -1200
(0xfffffb50)
no one knows what the -1200 error is - neither Informix support nor
Veritas ???
Thank you
Tom
Hi,
from the info given, it is not possible to tell much, because it is
not clear, where this error comes from. :-(
I have the following suspicion:
onbar connects to IDS to do some SQL queries on sysmaster and
sysutils databases in order to do the backup. One of these queries
returns error -1200, which in this context means:
-1200 Number is too large for a DECIMAL data type.
You can (try to) verify my theory by setting BAR_DEBUG value to
5 or higher in your onconfig file. Then run the command and check
in the file specified as BAR_DEBUG_LOG (also in you onconfig file)
where the error comes from.
IBM Informix Technical Support probably has told you this already.
Next interesting thing is the exact version of IDS (I suppose 10.00.FC5?)
and platform you are on (Solaris? Version??)?
I've seen this error before and it was an OS issue (with Solaris).
Only, then I thought that it was an issue with the compiler version that
we
used to build the product, and it was the vNext version of IDS (which is
not out yet).
Up to now I am not aware that this problem would have creeped into
any 10.00 version. If it turns out, that this is a problem in the Solaris
runtime environment (rather than the compiler), then it can occur with
10.00 as well, of course.
With these hints and the info from BAR_DEBUG_LOG get back to
IBM Informix Tech Support for more detailed analysis.
Regards,
Martin
--
Martin Fuerderer
IBM Informix Development Munich, Germany
Information Management
Informix URLs list: http://home.arcor.de/mfu1/informix/urls.html
informix-list-bounces@iiug.org wrote on 18.10.2006 18:49:05:
> Hello
>
> We are having problems with onabr and Veritas NetBackup. Our logical
> logs are bing backed up to tape just fine but when we try to kick off a
> level 0 on the Database, nothing gets written to the log.xxx file and
> the onbar command immediately comes back to screen and no messages.
> This is the only message we receive in bar_act.log :
>
> 2006-10-18 11:47:59 774338 241908
> /home/informix/iif2000/ids_10_FC5/bin/onbar_d -b -L 0
> 2006-10-18 11:47:59 774338 241908 Working with veritas-netbackup as
> generic storage manager.
> 2006-10-18 11:48:00 774338 241908
> /home/informix/iif2000/ids_10_FC5/bin/onbar_d complete, returning -1200
> (0xfffffb50)
>
>
> no one knows what the -1200 error is - neither Informix support nor
> Veritas ???
>
> Thank you
>
> Tom
>
> _______________________________________________
> Informix-list mailing list
> Informix-list@iiug.org
> http://www.iiug.org/mailman/listinfo/informix-list
Thanks Martin
We are in a clustered environment and it turns out it believed one of
the spaces was down.
Support worked it through for us and we had to drop a space and
recreate it.
I am seeing more "downed" dbspaces under AIX than I have ever
encountered - quite frightening.
Netbackup does not seem to play so well with others either.
Tom
Martin Fuerderer wrote:
> Hi,
>
> from the info given, it is not possible to tell much, because it is
> not clear, where this error comes from. :-(
>
> I have the following suspicion:
> onbar connects to IDS to do some SQL queries on sysmaster and
> sysutils databases in order to do the backup. One of these queries
> returns error -1200, which in this context means:
>
> -1200 Number is too large for a DECIMAL data type.
>
> You can (try to) verify my theory by setting BAR_DEBUG value to
> 5 or higher in your onconfig file. Then run the command and check
> in the file specified as BAR_DEBUG_LOG (also in you onconfig file)
> where the error comes from.
> IBM Informix Technical Support probably has told you this already.
>
> Next interesting thing is the exact version of IDS (I suppose 10.00.FC5?)
> and platform you are on (Solaris? Version??)?
>
> I've seen this error before and it was an OS issue (with Solaris).
> Only, then I thought that it was an issue with the compiler version that
> we
> used to build the product, and it was the vNext version of IDS (which is
> not out yet).
> Up to now I am not aware that this problem would have creeped into
> any 10.00 version. If it turns out, that this is a problem in the Solaris
> runtime environment (rather than the compiler), then it can occur with
> 10.00 as well, of course.
>
> With these hints and the info from BAR_DEBUG_LOG get back to
> IBM Informix Tech Support for more detailed analysis.
>
> Regards,
> Martin
> --
> Martin Fuerderer
> IBM Informix Development Munich, Germany
> Information Management
>
> Informix URLs list: http://home.arcor.de/mfu1/informix/urls.html
>
> informix-list-bounces@iiug.org wrote on 18.10.2006 18:49:05:
> > Hello
> >
> > We are having problems with onabr and Veritas NetBackup. Our logical
> > logs are bing backed up to tape just fine but when we try to kick off a
> > level 0 on the Database, nothing gets written to the log.xxx file and
> > the onbar command immediately comes back to screen and no messages.
> > This is the only message we receive in bar_act.log :
> >
> > 2006-10-18 11:47:59 774338 241908
> > /home/informix/iif2000/ids_10_FC5/bin/onbar_d -b -L 0
> > 2006-10-18 11:47:59 774338 241908 Working with veritas-netbackup as
> > generic storage manager.
> > 2006-10-18 11:48:00 774338 241908
> > /home/informix/iif2000/ids_10_FC5/bin/onbar_d complete, returning -1200
> > (0xfffffb50)
> >
> >
> > no one knows what the -1200 error is - neither Informix support nor
> > Veritas ???
> >
> > Thank you
> >
> > Tom
> >
> > _______________________________________________
> > Informix-list mailing list
> > Informix-list@iiug.org
> > http://www.iiug.org/mailman/listinfo/informix-list
Hi,
if you see "more down dbspaces" than expected, you may have to check
machine startup procedure (e.g. when re-booting). If you start IDS "too
early",
i.e. before all disks are fully available, then IDS will receive errors
upon its
own chunk checks that are done during IDS startup. If that happens, IDS
will
mark the chunk and dbspace as down. This is then kind of "irreversible"
by normal admin means. (You'd have to restore, which of course is not
really
necessary in this case).
To avoid this, I recommend to wait with IDS startup until all disks are
available,
especially when the disks are in an external storage device.
Possibly you can do some check (e.g. using dd) for all the involved
disks/devices
in a script before starting up IDS (in the same script) ...
Regards,
Martin
--
Martin Fuerderer
IBM Informix Development Munich, Germany
Information Management
Informix URLs list: http://home.arcor.de/mfu1/informix/urls.html
informix-list-bounces@iiug.org wrote on 19.10.2006 19:13:51:
> Thanks Martin
>
>
> We are in a clustered environment and it turns out it believed one of
> the spaces was down.
> Support worked it through for us and we had to drop a space and
> recreate it.
>
> I am seeing more "downed" dbspaces under AIX than I have ever
> encountered - quite frightening.
>
> Netbackup does not seem to play so well with others either.
>
> Tom
>
> Martin Fuerderer wrote:
> > Hi,
> >
> > from the info given, it is not possible to tell much, because it is
> > not clear, where this error comes from. :-(
> >
> > I have the following suspicion:
> > onbar connects to IDS to do some SQL queries on sysmaster and
> > sysutils databases in order to do the backup. One of these queries
> > returns error -1200, which in this context means:
> >
> > -1200 Number is too large for a DECIMAL data type.
> >
> > You can (try to) verify my theory by setting BAR_DEBUG value to
> > 5 or higher in your onconfig file. Then run the command and check
> > in the file specified as BAR_DEBUG_LOG (also in you onconfig file)
> > where the error comes from.
> > IBM Informix Technical Support probably has told you this already.
> >
> > Next interesting thing is the exact version of IDS (I suppose
10.00.FC5?)
> > and platform you are on (Solaris? Version??)?
> >
> > I've seen this error before and it was an OS issue (with Solaris).
> > Only, then I thought that it was an issue with the compiler version
that
> > we
> > used to build the product, and it was the vNext version of IDS (which
is
> > not out yet).
> > Up to now I am not aware that this problem would have creeped into
> > any 10.00 version. If it turns out, that this is a problem in the
Solaris
> > runtime environment (rather than the compiler), then it can occur with
> > 10.00 as well, of course.
> >
> > With these hints and the info from BAR_DEBUG_LOG get back to
> > IBM Informix Tech Support for more detailed analysis.
> >
> > Regards,
> > Martin
> > --
> > Martin Fuerderer
> > IBM Informix Development Munich, Germany
> > Information Management
> >
> > Informix URLs list: http://home.arcor.de/mfu1/informix/urls.html
> >
> > informix-list-bounces@iiug.org wrote on 18.10.2006 18:49:05:
> > > Hello
> > >
> > > We are having problems with onabr and Veritas NetBackup. Our logical
> > > logs are bing backed up to tape just fine but when we try to kick
off a
> > > level 0 on the Database, nothing gets written to the log.xxx file
and
> > > the onbar command immediately comes back to screen and no messages.
> > > This is the only message we receive in bar_act.log :
> > >
> > > 2006-10-18 11:47:59 774338 241908
> > > /home/informix/iif2000/ids_10_FC5/bin/onbar_d -b -L 0
> > > 2006-10-18 11:47:59 774338 241908 Working with veritas-netbackup
as
> > > generic storage manager.
> > > 2006-10-18 11:48:00 774338 241908
> > > /home/informix/iif2000/ids_10_FC5/bin/onbar_d complete, returning
-1200
> > > (0xfffffb50)
> > >
> > >
> > > no one knows what the -1200 error is - neither Informix support nor
> > > Veritas ???
> > >
> > > Thank you
> > >
> > > Tom
> > >
> > > _______________________________________________
> > > Informix-list mailing list
> > > Informix-list@iiug.org
> > > http://www.iiug.org/mailman/listinfo/informix-list
>
> _______________________________________________
> Informix-list mailing list
> Informix-list@iiug.org
> http://www.iiug.org/mailman/listinfo/informix-list