SQLEXECD PID DISAPPEARS
Posted in 1999
Topics: Error Codes & Troubleshooting, Connectivity: ODBC / JDBC / .NET, Server Administration, Security, Permissions & Auditing, Networking & sqlhosts Configuration, Platform-Specific Issues
I have a running informix SE server in a Linux env.. I tested the setup
with dbaccessdemo7 and dbaccess aplication. Everything works fine (I can
select and query the database etc.) only error occures when I try to
connect to a database environment (menu entry "Connection") with dbaccess.
I choose the db server, enter login and password, a line "Running ..."
appears for a while and terminates with the error:
908: Attempt to connect to database server (gambit_ifx) failed.
ISAM error: record is locked
During this operation the sqlexecd process terminates for unknown reason
(doesn`t appear in ps aux anymore).
INFORMIXDIR, INFORMIXSERVER, /etc/services are ptoperly set, I tried to set
DBNAME and DBPATH as well.
my sqlhosts file:
gambit_ifx sesoctcp gambit sqlexectcp
The same happens when I try to remote connect from Win NT using Informix
ODBC 3.30. However I can establish connection with ILogin and with Openlink
ODBC driver.
Any suggestions please?
Thank, oliver
oliver fodor wrote:
>
> I have a running informix SE server in a Linux env.. I tested the setup
> with dbaccessdemo7 and dbaccess aplication. Everything works fine (I can
> select and query the database etc.) only error occures when I try to
> connect to a database environment (menu entry "Connection") with dbaccess.
> I choose the db server, enter login and password, a line "Running ..."
> appears for a while and terminates with the error:
>
> 908: Attempt to connect to database server (gambit_ifx) failed.
> ISAM error: record is locked>
> During this operation the sqlexecd process terminates for unknown reason
> (doesn`t appear in ps aux anymore).
>
> INFORMIXDIR, INFORMIXSERVER, /etc/services are ptoperly set, I tried to set
> DBNAME and DBPATH as well.
>
> my sqlhosts file:
>
> gambit_ifx sesoctcp gambit sqlexectcp
>
> The same happens when I try to remote connect from Win NT using Informix
> ODBC 3.30. However I can establish connection with ILogin and with Openlink
> ODBC driver.
>
> Any suggestions please?
>
> Thank, oliver
I have a similar problem.
But verything is OK when I put a blank login password.
My problem, is that sqlexecd disappears (crash !) when I try to connect
with a remote client.