cannot initialize root dbspace
Posted in 2004
Topics: Storage & Space Management, Stored Procedures & SPL, Server Administration
$
oninit -iv
This action will initialize Informix Dynamic Server;
any existing Informix Dynamic Server databases will NOT be accessible -
Do you wish to continue (y/n)? y
Checking group membership to determine server run modesucceeded
Reading configuration file '/informix/etc/onconfig.imiti'...succeeded
Creating /INFORMIXTMP/.infxdirs ... succeeded
Creating infos file "/informix/etc/.infos.imiti" ...
"/informix/etc/.conf.imiti" ... succeeded
Writing to infos file ... succeeded
Checking config parameters...succeeded
Allocating and attaching to shared memory...succeeded
Creating resident pool 2016 kbytes...succeeded
Creating buffer pool 4002 kbytes...succeeded
Initializing rhead structure...succeeded
Initializing ASF ...succeeded
Initializing Dictionary Cache and Stored Procedure Cache...Cannot find message
file. Check INFORMIXDIR and DBLANG.FAILED
************** online.log *********
Mon Jul 12 08:45:52 2004
08:45:52 Event alarms enabled. ALARMPROG = '/informix/etc/log_full.sh'
Anyone please help me...
It appears that you have installed other IBM Informix products in the same directory. This error is usually caused by installing the products in the wrong order. You will need to reinstall some of the IBM Informix products. The correct order would be the lower version number first. If you are installing ClientSDK you should install it last since the ESQL/C should be a higher version then the engine.