ER problem / bug? in 11.50.UC3
Posted in 2009
Hi,
We are looking at 11.50.UC3 for an upgrade to ER and came across a funny
bit.
First - both servers are RHEL4 running 11.50.UC3.
One is called sirrp61 and the other Stan2 - note the capital letter in
the start of the name.
ER is established between the pair fine and replicates created.
When I go to sync a replicate it fails with the below - and it has used
a lower case version of the group number g_stan2 in the attempt to
connect message.
Now I know it isn't a good idea to let capital letters and Linux mix,
but worth noting.
Can you let me know if I am missing something here? otherwise I will
look to raise a PMR as a bug.
Thank
Jarrod Teale
Fonterra NZ
[informix@Stan2 ~]$ cdr list server
SERVER ID STATE STATUS QUEUE CONNECTION CHANGED
-----------------------------------------------------------------------
g_Stan2 100 Active Local 0
g_sirrp61 101 Active Connected 0 Feb 20 13:27:53
[informix@Stan2 ~]$ cdr sync repl -m g_sirrp61 -r sirrp61_stan2_tag_defn
g_Stan2
Creating Shadow Repl sync_5590_6553602_1235090243
Starting synchronization scan for replicate
sirrp61_stan2_tag_defn
Error returned from getReplColumns: prepare recheck_3 from select def_id
as def_id from stan2@g_Stan2:"sdev".tag_defn where def_id = ?
SQLCODE -908 ISAM 0
Error Details:
908: Attempt to connect to database server (g_stan2,
conerr=-25555, oserr=0) failed.
Current Connection:conn5, Database:stan2@g_Stan2
connect to Stan2 failed
unable to connect to server specified (5)
command failed -- unable to connect to server specified (5)
Error Details:
Could not connect to the specified server or database.
Perform the following actions and then run the above repair command
again:
1. Correct any misspelled server group names in the command.
2. Correct any misspelled or incorrectly formatted sqlhosts
entries
corresponding to the server groups specified in the command.
3. Ensure that all servers specified in the command are online.
4. If the error indicates a problem with the syscdr database,
then ensure
that ER is running on all the servers specified in the
command.
5. Ensure that the user who is running the command has CONNECT
permission
to the specified database.
DISCLAIMER:
This email contains confidential information and may be legally privileged. If
you are not the intended recipient or have received this email in error,
please notify the sender immediately and destroy this email.
You may not use, disclose or copy this email or its attachments in any way.
Any opinions expressed in this email are those of the author and are not
necessarily those of the Fonterra Co-operative Group.
http://www.fonterra.com/