Scheduler Status
Posted in 2013
Topics: General Discussion
IDS 11.7
I know how to stop and start the scheduler:
execute function task ("scheduler start");
execute function task ("scheduler stop");
..... but how do you check the status, to see if it is running or not ?
________________________________
NOTE: This e-mail message is subject to the MTN Group disclaimer see
http://www.mtn.co.za/SUPPORT/LEGAL/Pages/EmailDisclaimer.aspx
original post:
IDS 11.7
I know how to stop and start the scheduler:
execute function task ("scheduler start");
execute function task ("scheduler stop");
..... but how do you check the status, to see if it is running or not ?
Response:
You can run onstat -g dbc
If you see something like this:
onstat -g dbc
IBM Informix Dynamic Server Version 11.50.FC9 -- On-Line -- Up 00:00:47 --83412 Kbytes
Database Scheduler is Disabled.
It's shut off, if you then run the start task and run onstat -g dbc you'll see
something like this:
onstat -g dbc
IBM Informix Dynamic Server Version 11.50.FC9XL -- On-Line -- Up 00:02:32 --83412 Kbytes
Worker Thread(1) 47af64c0
=====================================
Task: 47af65c0
Task Name: mon_table_profile (9-6)
Task Type: SENSOR
WORKER PROFILE
Total Jobs Executed 1
Sensors Executed 1
Tasks Executed 0
Purge Requests 1
Rows Purged 0
Errors 0
Worker Thread(2) 47af6540
=====================================
Task: 47af6a58
Task Name: mon_table_names (10-4)
Task Type: SENSOR
Task Execution: tabnames_save_diffs
WORKER PROFILE
Total Jobs Executed 0
Sensors Executed 1
Tasks Executed 0
Purge Requests 1
Rows Purged 0
Errors 0
Private Worker Thread(3) 4777def8
=====================================
Task: 47bb0028
Task Name: Auto Update Statistics Evaluation (18-4)
Task Type: TASK
Task Execution: aus_evaluator
WORKER PROFILE
Total Jobs Executed 0
Sensors Executed 0
Tasks Executed 1
Purge Requests 1
Rows Purged 0
Errors 0
Scheduler Thread 4777de78
=====================================
Next Task 4
Next Task Waittime 55
General Queue size 3
full 0
empty 3
Private Queue size 1
full 0
empty 1
PRIVATE QUEUE TASKS
Total Jobs Executed 0
Sensors Executed 0
Tasks Executed 1
Purge Requests 1
Rows Purged 0
Errors 0
Jacques Renaut
IBM Informix Advanced Support
APD Team
Hi Dick,
1/ One way to check is to run
*onstat -g ath| grep dbScheduler*
you sould get one thread that looks like this:
576 20556b2a0 2032d22a8 1 sleeping secs: 247
1cpu dbScheduler
2/ Another way is to check the *systhreads* table in the sysmaster table
for the 'dbScheduler thread. You should get something like this after
running the following query:
*select * from sysmaster:systhreads where th_name='dbScheduler'*
th_name dbScheduler
th_id 619
th_addr 8682488136
th_joinlist 0
th_joinnext 0
th_joinee 0
th_name dbScheduler
th_state 7
th_priority 1
th_class 0
th_vpid 1
th_mtxwait 0
th_conwait 0
th_waketime 1358953868
th_startwait 1358953567
th_startrun 1358953568
The th_startrun is the start time :date and time when the scheduler
started (in seconds since 01/01/1970)
3/ You can also use
*onstat -g dbc*
The status of the scheduler is also sent out to the online.log (informix
message log) file: when it starts and when it stops.
Cordialement, Regards,
Khaled Bentebal
Directeur Général - ConsultiX
Président UGIF - User Group Informix France
IIUG - Board of Directors
Tél: 33 (0) 1 39 12 18 00
Fax: 33 (0) 1 39 12 18 18
Mobile: 33 (0) 6 07 78 41 97
Email: khaled.bentebal@consult-ix.fr
Site Web: www.consult-ix.fr
Le 23/01/13 12:09, Dirk Cornel.... a écrit :
> IDS 11.7
>
> I know how to stop and start the scheduler:
>
> execute function task ("scheduler start");>
> execute function task ("scheduler stop");>
> ...... but how do you check the status, to see if it is running or not ?
>
> ________________________________
> NOTE: This e-mail message is subject to the MTN Group disclaimer see
> http://www.mtn.co.za/SUPPORT/LEGAL/Pages/EmailDisclaimer.aspx
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
Great, thanks.
> -----Original Message-----
> From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of
> JACQUES RENAUT
> Sent: Wednesday, 23 January 2013 03:59 PM
> To: ids@iiug.org
> Subject: Re: Scheduler Status [29376]
>
> original post:
>
> IDS 11.7
>
> I know how to stop and start the scheduler:
>
> execute function task ("scheduler start");>
> execute function task ("scheduler stop");>
> ...... but how do you check the status, to see if it is running or not
> ?
>
> Response:
>
> You can run onstat -g dbc
>
> If you see something like this:
>
> onstat -g dbc>
> IBM Informix Dynamic Server Version 11.50.FC9 -- On-Line -- Up 00:00:47
> --> 83412 Kbytes
>
> Database Scheduler is Disabled.
>
> It's shut off, if you then run the start task and run onstat -g dbc
> you'll see
> something like this:
>
> onstat -g dbc>
> IBM Informix Dynamic Server Version 11.50.FC9XL -- On-Line -- Up
> 00:02:32 --> 83412 Kbytes
> Worker Thread(1) 47af64c0
> =====================================
> Task: 47af65c0
> Task Name: mon_table_profile (9-6)
> Task Type: SENSOR
> WORKER PROFILE
>
> Total Jobs Executed 1
>
> Sensors Executed 1
>
> Tasks Executed 0
>
> Purge Requests 1
>
> Rows Purged 0
>
> Errors 0
>
> Worker Thread(2) 47af6540
> =====================================
> Task: 47af6a58
> Task Name: mon_table_names (10-4)
> Task Type: SENSOR
> Task Execution: tabnames_save_diffs
> WORKER PROFILE
>
> Total Jobs Executed 0
>
> Sensors Executed 1
>
> Tasks Executed 0
>
> Purge Requests 1
>
> Rows Purged 0
>
> Errors 0
>
> Private Worker Thread(3) 4777def8
> =====================================
> Task: 47bb0028
> Task Name: Auto Update Statistics Evaluation (18-4)
> Task Type: TASK
> Task Execution: aus_evaluator
> WORKER PROFILE
>
> Total Jobs Executed 0
>
> Sensors Executed 0
>
> Tasks Executed 1
>
> Purge Requests 1
>
> Rows Purged 0
>
> Errors 0
>
> Scheduler Thread 4777de78
> =====================================
> Next Task 4
> Next Task Waittime 55
> General Queue size 3
>
> full 0
>
> empty 3
> Private Queue size 1
>
> full 0
>
> empty 1
> PRIVATE QUEUE TASKS
>
> Total Jobs Executed 0
>
> Sensors Executed 0
>
> Tasks Executed 1
>
> Purge Requests 1
>
> Rows Purged 0
>
> Errors 0
>
> Jacques Renaut
> IBM Informix Advanced Support
> APD Team
>
>
> ***********************************************************************
> ********
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
NOTE: This e-mail message is subject to the MTN Group disclaimer see
http://www.mtn.co.za/SUPPORT/LEGAL/Pages/EmailDisclaimer.aspx
Related threads
- Posting from the Informix-list
- Migrating from IDS 9.40.UC6 to 11.50.UC3
- Ip for a network session
- questions onstat -g