DR problems after breakdown
Posted in 1999
Topics: High Availability & Replication, Server Administration, Platform-Specific Issues, Versions, Editions & End-of-Life
Hi,
I have a problem with data replication (HDR). Setting it up works,
and everything runs as expeced; but when the secondary crashes and
I try to restart it (oninit, after that onmode -d secondary...), I
only get:
11:00:33 DR: new type = secondary, primary server name = prim_tcp
11:00:33 DR: Trying to connect to primary server ...
11:00:36 DR: Secondary server connected
11:00:37 DR: Failure recovery from disk in progress ...
11:00:37 DR: Failure during start of logical restore (1)
11:00:37 DR: Failure recovery error (6)
11:00:38 DR: Turned off on secondary server
11:00:38 DR: Failure during start of logical restore (1)
11:00:38 DR: new type = standard
I.e. it fails to start up the replication and acts as a standalone
server. I have to do a complete backup of the primary and re-initialize
the secondary with it every time.
I am using IDS 7.31U on Solaris/x86.
Thanks for any enlightenment,
Frederik
--
Frederik Ramm (frederik@remote.org)
In article <7una74$gq$1@guanaco.rhein-main.de>, Frederik Ramm
<frederik@remote.org> writes
>Hi,
>
> I have a problem with data replication (HDR). Setting it up works,
>and everything runs as expeced; but when the secondary crashes and
>I try to restart it (oninit, after that onmode -d secondary...), I
>only get:
>
>11:00:33 DR: new type = secondary, primary server name = prim_tcp
>11:00:33 DR: Trying to connect to primary server ...
>11:00:36 DR: Secondary server connected
>11:00:37 DR: Failure recovery from disk in progress ...
>11:00:37 DR: Failure during start of logical restore (1)
>11:00:37 DR: Failure recovery error (6)
>11:00:38 DR: Turned off on secondary server
>11:00:38 DR: Failure during start of logical restore (1)
>11:00:38 DR: new type = standard>
>I.e. it fails to start up the replication and acts as a standalone
>server. I have to do a complete backup of the primary and re-initialize
>the secondary with it every time.
>
What does
onstat -
give is it a secondary?
onmode -d secondary
??
>I am using IDS 7.31U on Solaris/x86.
>
>Thanks for any enlightenment,
>Frederik
>
--
David Williams