Re: dbaccess can't connect; ISQL can
Posted in 1999
Hi,
I have to disagree with Art. At least in my version of dbaccess
the error codes related to no user/no password are 951/952.
The error code 908 should be really related to some problems
in netwrok configuration (or when server is down).
Of course there could be a possibility that Carrie's
INFORMIXSERVER env variable is set to one value (and isql uses it)
and in dbaccess while connecting is selected another server. In this
case I would check also the sqlexecd daemon (since it is SE).
Carrie, try to check thoroughly your sqlhosts settings. Also you
could try checking that not only the direct mapping in your nameserver
works, but the reverse too (although I have doubts this reverse
mapping can give such results, but I think it's worth trying).
Best Regards,
Octav
P.S. I didn't work for a while with SE, so I could be wrong :-)
On Wed, Aug 18, 1999 at 02:38:26PM -0400, Art S. Kagel wrote:
> If you use the menu connect option in dbaccess it produces a CONNECT TO
> statement with the USER and USING options, which is why it prompts for
> them. In this case if the password is wrong, or the user has no password
> on the server, you get -908. Can you connect directly using dbaccess
> with any of:
>
> dbaccess somedatabase@remoteserver
>
> INFORMIXSERVER=remoteserver dbaccess somedatabase>
> dbaccess - -
> > connect to 'somedatabase@remoteserver';
>
> Connected.
>
> >^D
>
> dbaccess
> <Query><New>> connect to 'somedatabase@remoteserver';
> <Esc>
> <Run>
>
> If these work then it is the password problem. Can you login to the
> remote as that username using telnet? I set up PC users with no password
> and a .rhosts file so they can have database access but not login. In
> this case a CONNECT TO .... USER ... USING... will fail since there is no
> valid password.
>
> Art S. Kagel
>
> Carrie Coy wrote:
> >
> > Sorry, this doesn't help. ping and telnet both respond instantly, as does an
> > un-authenticated isql connection. it's something about the way db-access does
> > its magic that seems to be the problem.
> > --
> > Carrie Coy
> >
> > Octav Chiriac wrote:
> >
> > > 30 sec. ... check nameserver. I think it is the problem.
> > > Look in your sqlhosts file for host name (third field) and
> > > run one of:
> > > ping thirdfieldstring
> > > telnet thirdfieldstring
> > >
> > > It should be the same 30 secs of delay.
> > >
> > > Hope this helps,
> > > Octav
> > >
> > >
> > > On Wed, Aug 18, 1999 at 11:24:08AM -0400, Carrie Coy wrote:
> > > > I'm trying to get Apache+php+informix working from Linux web server to
> > > > SCO Unix Informix SE database.
> > > >
> > > > It's not working and I'm attempting to pinpoint where it's failing.
> > > > When I enter "isql" from client, the remote databases appear instantly.
> > > > When I try to connect using db-access, after I provide username and
> > > > password, the connection stalls for about 30 seconds, and then returns
> > > > error -908 Attempt to connect to database server (servername) failed.
> > > >
> > > > I've tested dbaccess from another nearly identical linux box to the same
> > > > Informix SE server and it works fine.
> > > >
> > > > What might be the problem?
> > > >
> > > > (Database server: Informix SE 7.12.UC1 on SCO Unix
> > > > Client: Apache+php 3.0.12 + Informix Client SDK 2.10.UC3 on linux)
> > > > --
> > > > Carrie Coy
> > >
--
Octav Chiriac Phone: (373) 2 22 99 67
NetInfo S.R.L. Fax: (373) 2 21 36 59
Chisinau (373) 2 22 84 88
Moldova, Republic of mailto:com@netinfo-moldova.com