Re: table privileges problem
khalid.zia writes: -> ->I altered some tables in our database recently, expanding one of the ->fields from 5 columns to 12 columns. Before doing that, I dropped ->(had to) the trails, and re-created them after altering the tables. -> ->I also re-complied the forms for the tables. -> ->The problem is that now when a user tries to update the table, he gets the ->error: -> ->Could not insert new row into the table. ->Permission denied. -> ->I checked the privileges on the table for the user: -> select=all, update=all, insert=yes, delete=yes. -> ->I checked the file permissions on the .dat and .idx files for the table: -> -rw-rw---- -> ->I checked the systabauth table, for the table/user: -> tabauth: su-id-- -> ->It happens not only on the tables I altered, but all tables in that database. ->The user cannot update, or insert, but can select and query the table. -> ->All users have the same problem. -> ->The DBA can insert and update data in the tables. -> ->We are running I-SQL (SE) 4.10.UC1 on a Sun4 machine. -> ->Does any one have a clue? -> -> ->Khalid Zia ->AT&T Bell Labs ->kz@mhcnet.att.com -> Khalid, Have you checked the permissions on your audit trail files and the directories where these files are. In standard engine, you need to make certain that your audit trail and transaction log files and the directories they reside in have appropriate permissions. Hope this helps! - Cathy -------------------------------------------------------------------------------- Cathy Kipp * These are my opin- * ckipp@vth1.vth.colostate.edu Colorado State University * ions and may not * Veterinary Teaching Hospital * represent anything * Phone: (303) 491-1294 Fort Collins, CO 80523 * at all relevant. * Fax: (303) 491-1205