Restore from Tape Failed
Posted in 2007
Topics: Storage & Space Management, Error Codes & Troubleshooting, Licensing & Editions, Jobs, Consulting & Announcements
Hi everyone,
I'm trying to restore a archive from tape. The machine it's not identical but
the OS Kernel and Informix release are.
I got HPUX B.11.11 U 9000/800 395670257 unlimited-user license
and 10.00.FC6 10 in both machines.
I tryied to do it 3 times and I got the same error message in distinct time.
The first one occours when informix was restoring the second chunks. The
second time I did it, the error message appear when Informix was restoring the
chunks number 6.
The chunks and dbspaces are the same (path name , size and offsets). But
that's the obscure part : I can Initialize the SERVER, add chunks, make a
several "down and up" and nothing wrong happens. The error just appears when
restore is running,
Check it out!
[informix - /home/informix]onstat -mshared memory not initialized for
INFORMIXSERVER 'baan_srv'
Message Log File: /informix/baan_srv.log15:16:33 See Also:
/var/tmp/af.400378015:16:34 I/O error, Primary Chunk
'/baan/informix/links/data06' -- Offline15:16:34 invoke_alarm(): /bin/sh -c
'/informix/log_full.sh 5 6 "Internal Subsystem failure: 'MT'" "I/O error,
Primary Chunk '/baan/informix/links/data06' -- Offline" '15:16:34
invoke_alarm(): mt_exec failed, status 32512, errno 015:16:34 Assert Warning:
I/O write chunk 7, pagenum 455064, pagecnt 2048 --> errno = 215:16:34 IBM
Informix Dynamic Server Version 10.00.FC615:16:34 Who: Session(6,
informix@hitachi5, 12507, c0000000379c48e8) Thread(24, physrecover,
c00000003798ba38, 1) File: rsbuff.c Line: 546215:16:34 Action: Please notify
IBM Informix Technical Support.15:16:34 stack trace for pid 12509 written to
/var/tmp/af.400378015:16:34 Process exited with return code 127: /bin/sh
/bin/sh -c /informix/log_full.sh 4 4 "Chunk is off-line, mirror is active: 7."
"I/O error, Primary Chunk '/baan/i15:16:34 See Also:
/var/tmp/af.400378015:16:35 I/O write chunk 7, pagenum 455064, pagecnt 2048
--> errno = 215:16:36 invoke_alarm(): /bin/sh -c '/informix/log_full.sh 5 6
"Internal Subsystem failure: 'MT'" "I/O write chunk 7, pagenum 455064, pagecnt
2048 --> errno = 2" '15:16:36 invoke_alarm(): mt_exec failed, status 32512,
errno 015:16:36 Aborting physical restore of ROOT DBSpace15:16:36 Aborted by
client.15:16:36 IBM Informix Dynamic Server Stopped.
[informix - /home/informix]cat /var/tmp/af.400378015:16:33
mt_aio_wait(c00000003827b578)15:16:33 chunkio(9, 0xc000000038ef3400, 0x6f198,
2048, 0xc000000038597b48, 34, 1) errno 2AIOREQ *aAIOREQ *ac0000000396f8870:
00000000 00000000 00000001 00000000 ........ ........c0000000396f8880:
00000002 00000002 00000000 00000000 ........ ........c0000000396f8890:
00000000 00000000 00000000 00000000 ........ ........c0000000396f88a0:
c0000000 3827b820 c0000000 3827b2d0 ....8'. ....8'..c0000000396f88b0: 00000000
00000000 00000000 00000000 ........ ........c0000000396f88c0: 00000f9e
41494f72 65710000 00000000 ....AIOr eq......c0000000396f88d0: 00000000
00000000 07d10000 00000000 ........ ........c0000000396f88e0: 00000000
00000000 00000003 00000901 ........ ........c0000000396f88f0: 00000001
00000002 00000001 00000000 ........ ........c0000000396f8900: 00000001
00000000 c0000000 3827b648 ........ ....8'.Hc0000000396f8910: 00000000
00000000 00000001 00000016 ........ ........c0000000396f8920: 00000001
00000000 00000000 00000000 ........ ........c0000000396f8930: 00000000
00000000 00000000 00000000 ........ ........15:16:3315:16:33 IBM Informix
Dynamic Server Version 10.00.FC6 Software Serial Number AAA#B000000
15:16:33 Assert Warning: I/O error, Primary Chunk
'/baan/informix/links/data06' -- Offline15:16:33 Who: Session(6,
informix@hitachi5, 12507, c0000000379c48e8) Thread(24, physrecover,
c00000003798ba38, 1) File: rsbuff.c Line: 512815:16:33 Results: Chunk is now
unusable15:16:33 Action: Repair and restore from mirror or archive15:16:33
Stack for thread: 24 physrecoverbase: 0xc0000000396f8000 len: 69632 pc: 0x0000000000000000 tos:
0xc0000000396f9890state: running vp: 1
( 0) 0x4000000000a3be3c legacy_hp_afstack + 0x25c [/informix/bin/oninit]( 1)
0x4000000000a3b48c afstack + 0x5c [/informix/bin/oninit]( 2)
0x4000000000a3a770 afhandler + 0x988 [/informix/bin/oninit]( 3)
0x4000000000a39d74 afwarn_interface + 0x4c [/informix/bin/oninit]( 4)
0x4000000000798fb4 chunkio + 0x654 [/informix/bin/oninit]( 5)
0x4000000000799694 physio + 0x634 [/informix/bin/oninit]( 6)
0x400000000089d2ec restore_dbs_page + 0x1a4 [/informix/bin/oninit]( 7)
0x400000000089be78 dophysrecvr + 0x560 [/informix/bin/oninit]( 8)
0x4000000000a11774 startup + 0xd4 [/informix/bin/oninit]( 9)
0x4000000000a1155c resume + 0x10c [/informix/bin/oninit]
base: 0xc0000000396f8000 len: 69632 pc: 0x0000000000000000 tos:
0xc0000000396f9890state: running vp: 1
15:16:33 See Also: /var/tmp/af.4003780
---------------------------------Begin System Alarm Program
Output---------------------------------
Assertion Failure Type: WarningHost Name: hitachi5Database Server Name:
baan_srvTime of failure: Sat Aug 18 15:16:34 SAT 2007AF file:
/var/tmp/af.4003780Shared memory file: NoneSystem Blocking: OFF
-------------------------------End System Alarm Program
Output-------------------------------
15:16:34 sh /informix/etc/evidence.sh 1 0 /var/tmp/af.4003780 6 0x3798ba38 24
0x386abb38 1025 0 0 0 015:16:34------------------ End of assertion failure 0
-----------------
15:16:3415:16:34 IBM Informix Dynamic Server Version 10.00.FC6 Software Serial
Number AAA#B000000
15:16:34 Assert Warning: I/O write chunk 7, pagenum 455064, pagecnt 2048 -->
errno = 215:16:34 Who: Session(6, informix@hitachi5, 12507, c0000000379c48e8)
Thread(24, physrecover, c00000003798ba38, 1) File: rsbuff.c Line: 546215:16:34
Action: Please notify IBM Informix Technical Support.15:16:34 Stack for
thread: 24 physrecover
base: 0xc0000000396f8000 len: 69632 pc: 0x0000000000000000 tos:
0xc0000000396f9500state: running vp: 1
( 0) 0x4000000000a3be3c legacy_hp_afstack + 0x25c [/informix/bin/oninit]( 1)
0x4000000000a3b48c afstack + 0x5c [/informix/bin/oninit]( 2)
0x4000000000a3a770 afhandler + 0x988 [/informix/bin/oninit]( 3)
0x4000000000a39d74 afwarn_interface + 0x4c [/informix/bin/oninit]( 4)
0x400000000079950c physio + 0x4ac [/informix/bin/oninit]( 5)
0x400000000089d2ec restore_dbs_page + 0x1a4 [/informix/bin/oninit]( 6)
0x400000000089be78 dophysrecvr + 0x560 [/informix/bin/oninit]( 7)
0x4000000000a11774 startup + 0xd4 [/informix/bin/oninit]( 8)
0x4000000000a1155c resume + 0x10c [/informix/bin/oninit]
base: 0xc0000000396f8000 len: 69632 pc: 0x0000000000000000 tos:
0xc0000000396f9500state: running vp: 1
15:16:34 See Also: /var/tmp/af.4003780
---------------------------------Begin System Alarm Program
Output---------------------------------
Assertion Failure Type: WarningHost Name: hitachi5Database Server Name:
baan_srvTime of failure: Sat Aug 18 15:16:35 SAT 2007AF file:
/var/tmp/af.4003780Shared memory file: NoneSystem Blocking: OFF
-------------------------------End System Alarm Program
Output-------------------------------
15:16:35 sh /informix/etc/evidence.sh 1 0 /var/tmp/af.4003780 6 0x3798ba38 24
0x386abb38 1025 0 0 0 015:16:35------------------ End of assertion failure 1
-----------------
ANYBODY PLEASE?
THANKS,
André Luiz
_______________________________
When you are doing the restore it is trying to write at byte position
931971072 (455064 pages) into chunk 7.
The problem is the file associated with chunk 7 does not exists (errno =
2).
I would locate which chunk is associated with
chunk 7 and sure that it exists and is large enough.
"I/O write chunk 7, pagenum 455064, pagecnt 2048 --> errno =3D 2"
John
=
"Andr=E9 Luiz =
Rufino" =
<andre_rufino@msn =
To
.com> ids@iiug.org =
Sent by: =
cc
ids-bounces@iiug. =
org Subj=
ect
Restore from Tape Failed [9817]=
=
08/18/2007 11:35 =
AM =
=
=
Please respond to =
ids@iiug.org =
=
=
Hi everyone,
I'm trying to restore a archive from tape. The machine it's not identic=
al
but
the OS Kernel and Informix release are.
I got HPUX B.11.11 U 9000/800 395670257 unlimited-user license
and 10.00.FC6 10 in both machines.
I tryied to do it 3 times and I got the same error message in distinct
time.
The first one occours when informix was restoring the second chunks. Th=
e
second time I did it, the error message appear when Informix was restor=
ing
the
chunks number 6.
The chunks and dbspaces are the same (path name , size and offsets). Bu=
t
that's the obscure part : I can Initialize the SERVER, add chunks, make=
a
several "down and up" and nothing wrong happens. The error just appears=
when
restore is running,
Check it out!
[informix - /home/informix]onstat -mshared memory not initialized for
INFORMIXSERVER 'baan_srv'
Message Log File: /informix/baan_srv.log15:16:33 See Also:
/var/tmp/af.400378015:16:34 I/O error, Primary Chunk
'/baan/informix/links/data06' -- Offline15:16:34 invoke_alarm(): /bin/s=
h -c
'/informix/log_full.sh 5 6 "Internal Subsystem failure: 'MT'" "I/O erro=
r,
Primary Chunk '/baan/informix/links/data06' -- Offline" '15:16:34
invoke_alarm(): mt_exec failed, status 32512, errno 015:16:34 Assert
Warning:
I/O write chunk 7, pagenum 455064, pagecnt 2048 --> errno =3D 215:16:34=
IBM
Informix Dynamic Server Version 10.00.FC615:16:34 Who: Session(6,
informix@hitachi5, 12507, c0000000379c48e8) Thread(24, physrecover,
c00000003798ba38, 1) File: rsbuff.c Line: 546215:16:34 Action: Please
notify
IBM Informix Technical Support.15:16:34 stack trace for pid 12509 writt=
en
to
/var/tmp/af.400378015:16:34 Process exited with return code 127: /bin/s=
h
/bin/sh -c /informix/log_full.sh 4 4 "Chunk is off-line, mirror is acti=
ve:
7."
"I/O error, Primary Chunk '/baan/i15:16:34 See Also:
/var/tmp/af.400378015:16:35 I/O write chunk 7, pagenum 455064, pagecnt =
2048
--> errno =3D 215:16:36 invoke_alarm(): /bin/sh -c '/informix/log_full.=
sh 5 6
"Internal Subsystem failure: 'MT'" "I/O write chunk 7, pagenum 455064,
pagecnt
2048 --> errno =3D 2" '15:16:36 invoke_alarm(): mt_exec failed, status =
32512,
errno 015:16:36 Aborting physical restore of ROOT DBSpace15:16:36 Abort=
ed
by
client.15:16:36 IBM Informix Dynamic Server Stopped.
[informix - /home/informix]cat /var/tmp/af.400378015:16:33
mt_aio_wait(c00000003827b578)15:16:33 chunkio(9, 0xc000000038ef3400,
0x6f198,
2048, 0xc000000038597b48, 34, 1) errno 2AIOREQ *aAIOREQ *ac0000000396f8=
870:
00000000 00000000 00000001 00000000 ........ ........c0000000396f8880:
00000002 00000002 00000000 00000000 ........ ........c0000000396f8890:
00000000 00000000 00000000 00000000 ........ ........c0000000396f88a0:
c0000000 3827b820 c0000000 3827b2d0 ....8'. ....8'..c0000000396f88b0:
00000000
00000000 00000000 00000000 ........ ........c0000000396f88c0: 00000f9e
41494f72 65710000 00000000 ....AIOr eq......c0000000396f88d0: 00000000
00000000 07d10000 00000000 ........ ........c0000000396f88e0: 00000000
00000000 00000003 00000901 ........ ........c0000000396f88f0: 00000001
00000002 00000001 00000000 ........ ........c0000000396f8900: 00000001
00000000 c0000000 3827b648 ........ ....8'.Hc0000000396f8910: 00000000
00000000 00000001 00000016 ........ ........c0000000396f8920: 00000001
00000000 00000000 00000000 ........ ........c0000000396f8930: 00000000
00000000 00000000 00000000 ........ ........15:16:3315:16:33 IBM Inform=
ix
Dynamic Server Version 10.00.FC6 Software Serial Number AAA#B000000
15:16:33 Assert Warning: I/O error, Primary Chunk
'/baan/informix/links/data06' -- Offline15:16:33 Who: Session(6,
informix@hitachi5, 12507, c0000000379c48e8) Thread(24, physrecover,
c00000003798ba38, 1) File: rsbuff.c Line: 512815:16:33 Results: Chunk i=
s
now
unusable15:16:33 Action: Repair and restore from mirror or archive15:16=
:33
Stack for thread: 24 physrecoverbase: 0xc0000000396f8000 len: 69632 pc: 0x0000000000000000 tos:
0xc0000000396f9890state: running vp: 1
( 0) 0x4000000000a3be3c legacy_hp_afstack + 0x25c [/informix/bin/oninit=
](
1)
0x4000000000a3b48c afstack + 0x5c [/informix/bin/oninit]( 2)
0x4000000000a3a770 afhandler + 0x988 [/informix/bin/oninit]( 3)
0x4000000000a39d74 afwarn_interface + 0x4c [/informix/bin/oninit]( 4)
0x4000000000798fb4 chunkio + 0x654 [/informix/bin/oninit]( 5)
0x4000000000799694 physio + 0x634 [/informix/bin/oninit]( 6)
0x400000000089d2ec restore_dbs_page + 0x1a4 [/informix/bin/oninit]( 7)
0x400000000089be78 dophysrecvr + 0x560 [/informix/bin/oninit]( 8)
0x4000000000a11774 startup + 0xd4 [/informix/bin/oninit]( 9)
0x4000000000a1155c resume + 0x10c [/informix/bin/oninit]
base: 0xc0000000396f8000 len: 69632 pc: 0x0000000000000000 tos:
0xc0000000396f9890state: running vp: 1
15:16:33 See Also: /var/tmp/af.4003780
---------------------------------Begin System Alarm Program
Output---------------------------------
Assertion Failure Type: WarningHost Name: hitachi5Database Server Name:=
baan_srvTime of failure: Sat Aug 18 15:16:34 SAT 2007AF file:
/var/tmp/af.4003780Shared memory file: NoneSystem Blocking: OFF
-------------------------------End System Alarm Program
Output-------------------------------
15:16:34 sh /informix/etc/evidence.sh 1 0 /var/tmp/af.4003780 6 0x3798b=
a38
24
0x386abb38 1025 0 0 0 015:16:34------------------ End of assertion fail=
ure
0
-----------------
15:16:3415:16:34 IBM Informix Dynamic Server Version 10.00.FC6 Software=
Serial
Number AAA#B000000
15:16:34 Assert Warning: I/O write chunk 7, pagenum 455064, pagecnt 204=
8
-->
errno =3D 215:16:34 Who: Session(6, informix@hitachi5, 12507,
c0000000379c48e8)
Thread(24, physrecover, c00000003798ba38, 1) File: rsbuff.c Line:
546215:16:34
Action: Please notify IBM Informix Technical Support.15:16:34 Stack for=
thread: 24 physrecover
base: 0xc0000000396f8000 len: 69632 pc: 0x0000000000000000 tos:
0xc0000000396f9500state: running vp: 1
( 0) 0x4000000000a3be3c legacy_hp_afstack + 0x25c [/informix/bin/oninit=
](
1)
0x4000000000a3b48c afstack + 0x5c [/informix/bin/oninit]( 2)
0x4000000000a3a770 afhandler + 0x988 [/informix/bin/oninit]( 3)
0x4000000000a39d74 afwarn_interface + 0x4c [/informix/bin/oninit]( 4)
0x4000000000