Re: No Exception Handler - Update - Final Fix
Posted in 2001
Just for those of you, who like to search through the archives for help
before posting a question (yes, it does happen!)
The final solution to the problem was to upgrade to 7.30 TC9. Why?
The problem first surfaced with the push to get to Y2K compatibility.
Microsoft dictated that clients had to be on Windows NT 4.0 and Service Pack
4. To be compatible with Service Pack 4, clients had to upgrade the
INFORMIX version to 7.30.,TC7 and those clients who had more than 25-35
simultaneous users ran into this soctcplst error displayed in my case.
The 7.30.TC9 level with a patch to correct the problem is the solution.
There are a few clients who have been continuously running on the TC7
version without any problems due to the fact their load did not trigger this
error. (Apparently we finally hit that load level threshold.) Should that
simultaneous user/thread load increase, they will encounter the same error.
The only solutions are to limit your user activity which is unacceptable or
upgrade to the TC9X2 version.
Hope this helps someone in the near future.
Wynne
p.s. Art, thanks for the help on getting the information, what you said
worked!!!
"Impy" <wlinden@stritch.edu> wrote in message news:...
> Happened a third time.
> 11:54:57 Assert Failed: No Exception Handler
> 11:54:57 Informix Dynamic Server Version 7.30.TC7
> 11:54:57 Who: Session(0, @, 0, 0)
> Thread(5, vp 0, 0, 8)
> Exception at Addr: 0x77f7cfd2, TOS: 0x3f1c1ce8,
> FP:0x3f1c1d10, E> xc: c0000005
> 11:54:57 Results: Exception Caught. Type: MT_EX_OS, Context: mem
> 11:54:57 Action: Please notify Informix Technical Support.
> 11:54:57 Checkpoint Completed: duration was 7 seconds.
> 11:55:26 See Also: af.5fef1
> 11:55:26 *, line -1, thread 5, proc id 318, No Exception Handler.>
> "Impy" <wlinden@stritch.edu> wrote in message
> news:93ctj2$9drib$1@ID-51564.news.dfncis.de...
> > My online system is in "Monday Mode" and refuses to work, thus taking
away
> > time I could be spending with my new love...
> >
> > Informix Dynamic Server Version 7.30.TC7
> > NT 4.0 SP4
> >
> > Here are my errors from the log:
> > First time it happened.
> >
> > 09:28:30 Assert Failed: No Exception Handler
> > 09:28:30 Informix Dynamic Server Version 7.30.TC7
> > 09:28:30 Who: Session(751, informix@, 0, 0)
> > Thread(10, soctcplst, 0, 4)
> > Exception at Addr: 0x77f7cfd2, TOS: 0x3f25f428, FP:0x3f25f450, Exc:> > c0000005
> > 09:28:30 Results: Exception Caught. Type: MT_EX_OS, Context: mem
> > 09:28:30 Action: Please notify Informix Technical Support.
> > 09:28:53 See Also: af.adc9d
> > 09:28:53 \