Database Drop PROBLEM SOLVED!
Posted in 1992
Our mailer is having problems, so i'll just post this, since many people seem to have to same problem. naomi Thanks to some golden advice from Bob Baskett (thank you), I have fixed the problem with the bad database and table I could not drop. This is not for the weak of heart, expecially when working on a production system, and I do not encourage this mucking about if you are not desperate (disclaimer). Here is what I did, following Bob's directions: 1. create a table with the exact schema as the one giving you trouble. (for this example - use new_tab) NOTE: I could not do a schema on the bad database. I created the schema from a similar test database. 2. get the partnum for new_tab and the old_tab (one causing problems) from the systables. 3. update systables - switching the partnums for the two tables. 4. delete from systables,syscolumns,sysindexs for tabid = tabid of new_tab 5. drop old_tab. This should have worked, but I got the error: "311 - Cannot Open System Catalogs (syscolumns)" 6. I unloaded the rows from syscolumns from the similar database, same table. 7. I changed the tabid's to match the table in the bad database. 8. Again I tried to delete the table, but this time got: "311 - Cannot Open System Catalogs (sysindexes)" So I followed the procedure I used in step 6 and 7 and dumped the sysindexes rows, and loaded them in the bad database. 9. At this point, I was able to drop the table, and then the database. Oh, boy! I had fun, and am dangerous now that I am more confident changing system catalogs (ONLY if I have to, of course). Thanks again, Bob, for your help (and Simon David). I did not look forward to unloading all the databases in the partition. Naomi -- Naomi Walker (aka N7FSA) naomi%anasaz.UUCP@asuvax.eas.asu.edu Enthusiasm is caught, In tennis, not taught. love means nothing. -- Naomi Walker (aka N7FSA) Anasazi Inc. Phoenix, Arizona 602-395-1731 {uunet!pyramid},{sun!sunburn!gtx!},{asuvax} !anasaz!qip!naomi